Bug 521844 - nfs-utils init scripts don't support "try-restart" option
nfs-utils init scripts don't support "try-restart" option
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: InitScriptsProject
  Show dependency treegraph
 
Reported: 2009-09-08 10:10 EDT by Yulia Kopkova
Modified: 2010-10-28 18:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.1-6.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 18:16:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yulia Kopkova 2009-09-08 10:10:00 EDT
Description of problem:
According to https://fedoraproject.org/wiki/Packaging/SysVInitScript
nfs-utils services should support "try-restart" option.

The reason of filling this is "InitScripts LSB compliance project"


Version-Release number of selected component (if applicable):
nfs-utils-1.2.0-10.fc12.x86_64

How reproducible:
Always

Steps to Reproduce:
1. service $SERVICE try-restart ; echo $?
2.
3.
  
Actual results:
Usage message and exit code 3

Expected results:
Restart if service is running

Additional info:
Comment 1 Bug Zapper 2009-11-16 07:03:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fedora Update System 2010-10-20 10:45:17 EDT
nfs-utils-1.2.1-6.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/nfs-utils-1.2.1-6.fc12
Comment 4 Fedora Update System 2010-10-21 01:58:36 EDT
nfs-utils-1.2.1-6.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nfs-utils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/nfs-utils-1.2.1-6.fc12
Comment 5 Fedora Update System 2010-10-28 18:16:00 EDT
nfs-utils-1.2.1-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.