Bug 521915 - gmixer shows no tray icon
Summary: gmixer shows no tray icon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gmixer
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 17:31 UTC by Christoph Wickert
Modified: 2009-09-24 05:21 UTC (History)
1 user (show)

Fixed In Version: 1.3-9.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 05:15:19 UTC


Attachments (Terms of Use)
/etc/xdg/autostart/gmixer-trayicon.desktop (456 bytes, text/plain)
2009-09-20 22:31 UTC, Christoph Wickert
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 427515 None None None Never

Description Christoph Wickert 2009-09-08 17:31:35 UTC
Description of problem:
According to it's description and the homepage, this app should have a tray icon, but I can't seem to find it.

Version-Release number of selected component (if applicable):
gmixer-1.3-4.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. start gmixer
  
Actual results:
no tray icon appears

Expected results:
icon in the systray

Additional info:
No errors on the console. All files are in place. I have tried different users and desktops including Gnome, Xfce and LXDE.

Comment 1 leigh scott 2009-09-10 16:53:18 UTC
Hi Christoph,

I also have the same here, could you file a bug report upstream ( I will do the same when I have finished moving house ).

https://bugs.launchpad.net/gmixer

Thanks

Leigh

Comment 2 Christoph Wickert 2009-09-10 19:59:34 UTC
Done: https://bugs.launchpad.net/gmixer/+bug/427515

Comment 3 leigh scott 2009-09-18 20:56:21 UTC
Ok I have done a bit of research and found that gmixer needs to be launched with the -d flag 'gmixer -d' to run as a daemon and show the tray icon.

gmixer-1.3-7.fc11 should fix the issue. 

http://koji.fedoraproject.org/koji/buildinfo?buildID=132669

Comment 4 Fedora Update System 2009-09-18 21:04:09 UTC
gmixer-1.3-7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gmixer-1.3-7.fc11

Comment 5 Fedora Update System 2009-09-18 21:05:31 UTC
gmixer-1.3-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gmixer-1.3-7.fc10

Comment 6 Christoph Wickert 2009-09-20 22:29:52 UTC
(In reply to comment #3)
> Ok I have done a bit of research and found that gmixer needs to be launched
> with the -d flag 'gmixer -d' to run as a daemon and show the tray icon.

Hmm, not sure if this was a good idea, because now when a user clicks on the launcher the first time, only the icon appears. IMO you should install a separate launcher for the autostart.

Comment 7 Christoph Wickert 2009-09-20 22:31:54 UTC
Created attachment 361843 [details]
/etc/xdg/autostart/gmixer-trayicon.desktop

I have also added German translations, please apply them in gmixer.desktop too.

Comment 8 Christoph Wickert 2009-09-20 22:33:13 UTC
(In reply to comment #7)
> /etc/xdg/applications/gmixer-trayicon.desktop

should read /etc/xdg/autostart/gmixer-trayicon.desktop

Comment 9 leigh scott 2009-09-21 10:53:29 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > /etc/xdg/applications/gmixer-trayicon.desktop
> 
> should read /etc/xdg/autostart/gmixer-trayicon.desktop  

Ok, I have made the changes you suggested.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1694385

Comment 10 Fedora Update System 2009-09-21 17:23:39 UTC
gmixer-1.3-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gmixer-1.3-9.fc11

Comment 11 Fedora Update System 2009-09-21 17:24:26 UTC
gmixer-1.3-9.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gmixer-1.3-9.fc10

Comment 12 Fedora Update System 2009-09-24 05:15:14 UTC
gmixer-1.3-9.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2009-09-24 05:21:02 UTC
gmixer-1.3-9.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.