Bug 521970 - Sound has stopped working for snd_hda_intel after recent kernel and pulseaudio upgrade
Summary: Sound has stopped working for snd_hda_intel after recent kernel and pulseaudi...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 21:43 UTC by Eric Hopper
Modified: 2010-06-28 14:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:32:52 UTC


Attachments (Terms of Use)
Output of alsa-info.sh (30.77 KB, text/plain)
2009-09-08 21:54 UTC, Eric Hopper
no flags Details
Log output of pulseaudio (75.08 KB, text/x-log)
2009-09-25 04:14 UTC, Eric Hopper
no flags Details

Description Eric Hopper 2009-09-08 21:43:45 UTC
My sound isn't working at all after the pulseaudio and kernel upgrade.  It seems to be the kernel driver at fault.  I get a popping noise in my speaker when pulseaudio initializes it, but after that no sound.  I was getting sound just fine before.  I've played with any volume control I could find, including gst-mixer, alsamixer and others.  I've also tried playback with aplay that bypassed pulseaudio.  

Here is a dump of various bits of system information:

---------------

uname -a
Linux bats.omnifarious.org 2.6.30.5-43.fc11.x86_64 #1 SMP Thu Aug 27 21:39:52 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

---------------

lsmod | fgrep snd
snd_hda_codec_realtek   281476  1 
snd_hda_intel          30488  3 
snd_hda_codec          78608  2 snd_hda_codec_realtek,snd_hda_intel
snd_usb_audio         100176  2 
snd_usb_lib            19504  1 snd_usb_audio
snd_pcm                88440  4 snd_hda_intel,snd_hda_codec,snd_usb_audio
snd_rawmidi            25792  1 snd_usb_lib
snd_timer              24224  1 snd_pcm
snd_seq_device          8308  1 snd_rawmidi
snd_hwdep               9736  2 snd_hda_codec,snd_usb_audio
snd_page_alloc         10064  2 snd_hda_intel,snd_pcm
snd                    73016  19
snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_usb_lib,snd_pcm,snd_rawmidi,snd_timer,snd_seq_device,snd_hwdep
soundcore               7584  1 snd

---------------

rpm -qa | egrep 'pulseaudio|alsa'
alsa-lib-1.0.21-1.fc11.x86_64
wine-pulseaudio-1.1.23-1.fc11.i586
alsa-lib-1.0.21-1.fc11.i586
alsa-plugins-pulseaudio-1.0.20-2.fc11.i586
pulseaudio-module-gconf-0.9.15-17.fc11.x86_64
pulseaudio-libs-0.9.15-17.fc11.x86_64
pulseaudio-0.9.15-17.fc11.x86_64
pulseaudio-libs-glib2-0.9.15-17.fc11.x86_64
alsa-utils-1.0.21-1.fc11.x86_64
pulseaudio-utils-0.9.15-17.fc11.x86_64
xine-lib-pulseaudio-1.1.16.3-2.fc11.x86_64
pulseaudio-libs-0.9.15-17.fc11.i586
pulseaudio-module-x11-0.9.15-17.fc11.x86_64
alsa-plugins-pulseaudio-1.0.20-2.fc11.x86_64

---------------

lspci -v -s 00:06.1
00:06.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
 Subsystem: Tyan Computer Device 2915
 Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
 Memory at 90000000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: [44] Power Management version 2
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
 Capabilities: [6c] HyperTransport: MSI Mapping Enable+ Fixed+
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Comment 1 Eric Hopper 2009-09-08 21:54:01 UTC
Created attachment 360139 [details]
Output of alsa-info.sh

Comment 2 Michal Jaegermann 2009-09-09 02:36:33 UTC
See also bug #521997 but with snd_via82xx there I still have "leftovers" of sound, not really usable, and rebooting the previous kernel restores sound to normal with all pulseaudio and alsa current updates applied.

Comment 3 Lubomir Rintel 2009-09-15 16:59:16 UTC
Please attach logs from pulseaudio (grep pulse /var/log/messages, pulseaudio -k && pulseaudio -vvv may come handy)

Comment 4 Michal Jaegermann 2009-09-18 02:38:05 UTC
Re: comment #3.
OP does not seem to be in a hurry with requested logs and I "recovered" my sound like described in https://bugzilla.redhat.com/show_bug.cgi?id=521997#c4 (cf. also fifth comment there).  Still I tried to see what I can do.

Search for pulse in /var/log/messages does not bring anything.  For "come handy" as a user 'pulseaudio -vvv' produces only a bit of output on stderr.  OTOH when doing that from 'root' then 'pulseaudio -k' errors out with "E: main.c: Failed to kill daemon: No such process".  'pulseaudio -vvv' for root will dump quite a lot on stderr but it has to be killed because it stops with "I: alsa-sink.c: Device suspended...".

So taking into account the above and that I "fixed" my broken sound, which is using snd_via82xx and not snd_hda_intel, what do you really want to see?  My outputs from alsa-info are attached to bug #521997.

Comment 5 Eric Hopper 2009-09-18 02:46:31 UTC
I will provide the requested logs, but right now I am running an old kernel that doesn't have the problem.  I am loathe to reboot my system as I habitually have many windows up that record the state of several long-term ongoing tasks.  I will though sometime this weekend.

Comment 6 Eric Hopper 2009-09-25 04:14:46 UTC
Created attachment 362609 [details]
Log output of pulseaudio

I've now added the log output of pulseaudio started with -vvv and logging to stderr on my broken kernel.

Comment 7 Eric Hopper 2009-10-23 23:37:59 UTC
I provided the requested logs, but the most recent kernel I downloaded still didn't have a fix for this.  Is anybody looking into this?

Comment 8 Pierre Blavy 2009-11-21 00:57:15 UTC
I get no sound with the same card. LSPCI do not says the same thing as KDE device manadger



[root@grosPC ~]# lspci -v -s 00:0e.1
00:0e.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
        Subsystem: ASUSTeK Computer Inc. Device 81f6                         
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 20             
        Memory at fe020000 (32-bit, non-prefetchable) [size=16K]             
        Capabilities: [44] Power Management version 2                        
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+           
        Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+        
        Kernel driver in use: HDA Intel                                      
        Kernel modules: snd-hda-intel

KDE device manadger see this device as an ethernet card.
screenshot
http://yfrog.com/2mcapturedcran1op

details
http://yfrog.com/e6capturedcran2p

Comment 9 Pierre Blavy 2009-11-26 16:07:12 UTC
FIXED for me with 26 nov update of pulseaudio, kernel (and some others parckages) from testing repository.


Updated packages list:
cat /var/log/yum.log |grep Nov\ 26 |sort

Nov 26 10:11:14 Updated: file-libs-5.03-11.fc12.x86_64                             
Nov 26 10:11:15 Updated: libmikmod-3.2.0-9.beta2.fc12.x86_64                       
Nov 26 10:11:16 Updated: file-5.03-11.fc12.x86_64                                  
Nov 26 10:11:17 Updated: sip-4.9.3-1.fc12.x86_64                                   
Nov 26 10:11:18 Updated: fedora-usermgmt-default-fedora-setup-0.10-1200.fc12.noarch
Nov 26 10:11:19 Updated: fedora-usermgmt-core-0.10-1200.fc12.noarch                
Nov 26 10:11:19 Updated: fontpackages-filesystem-1.35-1.fc12.noarch                
Nov 26 10:11:20 Updated: fedora-usermgmt-shadow-utils-0.10-1200.fc12.noarch        
Nov 26 10:11:21 Updated: fedora-usermgmt-0.10-1200.fc12.noarch                     
Nov 26 15:30:58 Updated: pulseaudio-libs-0.9.21-1.fc12.x86_64                      
Nov 26 15:30:59 Updated: ibus-libs-1.2.0.20091124-1.fc12.x86_64                    
Nov 26 15:31:00 Installed: xmlrpc-c-1.16.24-1200.1840.fc12.x86_64                  
Nov 26 15:31:02 Installed: xmlrpc-c-client-1.16.24-1200.1840.fc12.x86_64           
Nov 26 15:31:03 Updated: abrt-libs-1.0.0-1.fc12.x86_64                             
Nov 26 15:31:08 Updated: abrt-1.0.0-1.fc12.x86_64                                  
Nov 26 15:31:11 Updated: system-config-printer-libs-1.1.13-11.fc12.x86_64          
Nov 26 15:31:14 Updated: abrt-plugin-kerneloopsreporter-1.0.0-1.fc12.x86_64        
Nov 26 15:31:15 Updated: pulseaudio-libs-glib2-0.9.21-1.fc12.x86_64                
Nov 26 15:31:16 Updated: pulseaudio-utils-0.9.21-1.fc12.x86_64                     
Nov 26 15:31:19 Updated: lftp-4.0.4-1.fc12.x86_64                                  
Nov 26 15:31:20 Updated: libklfbackend-3.1.2-1.fc12.x86_64                         
Nov 26 15:31:21 Updated: lockdev-1.0.1-17.fc12.x86_64                              
Nov 26 15:31:22 Updated: sqlite-3.6.20-1.fc12.x86_64                               
Nov 26 15:31:24 Updated: linuxwacom-0.8.2.2-15.fc12.x86_64                         
Nov 26 15:31:25 Updated: 1:libvorbis-1.2.3-4.fc12.x86_64                           
Nov 26 15:31:27 Updated: abrt-addon-kerneloops-1.0.0-1.fc12.x86_64                 
Nov 26 15:31:27 Updated: system-config-printer-udev-1.1.13-11.fc12.x86_64          
Nov 26 15:31:31 Updated: 2:nmap-5.00-4.fc12.x86_64                                 
Nov 26 15:31:33 Updated: 1:telepathy-mission-control-5.2.6-1.fc12.x86_64           
Nov 26 15:31:40 Updated: python-reportlab-2.3-2.fc12.x86_64                        
Nov 26 15:31:43 Updated: kernel-firmware-2.6.31.6-145.fc12.noarch
Nov 26 15:31:47 Updated: xkeyboard-config-1.6-4.fc12.noarch
Nov 26 15:31:52 Updated: 1:control-center-filesystem-2.28.1-8.fc12.x86_64
Nov 26 15:31:52 Updated: sos-1.8-18.fc12.noarch
Nov 26 15:31:58 Updated: kernel-headers-2.6.31.6-145.fc12.x86_64
Nov 26 15:31:59 Updated: sqlite-3.6.20-1.fc12.i686
Nov 26 15:32:00 Updated: pulseaudio-libs-0.9.21-1.fc12.i686
Nov 26 15:32:01 Updated: 1:libvorbis-1.2.3-4.fc12.i686
Nov 26 15:32:06 Updated: coreutils-7.6-7.fc12.x86_64
Nov 26 15:32:07 Updated: coreutils-libs-7.6-7.fc12.x86_64
Nov 26 15:32:25 Updated: ibus-1.2.0.20091124-1.fc12.x86_64
Nov 26 15:32:27 Updated: ibus-gtk-1.2.0.20091124-1.fc12.x86_64
Nov 26 15:32:28 Updated: 1:perl-Module-Pluggable-3.90-85.fc12.x86_64
Nov 26 15:33:39 Installed: kernel-2.6.31.6-145.fc12.x86_64
Nov 26 15:33:43 Updated: pulseaudio-0.9.21-1.fc12.x86_64
Nov 26 15:33:44 Updated: pulseaudio-module-x11-0.9.21-1.fc12.x86_64
Nov 26 15:33:47 Updated: 1:smartmontools-5.38-23.fc12.x86_64
Nov 26 15:33:48 Updated: 12:dhclient-4.1.0p1-14.fc12.x86_64
Nov 26 15:34:11 Updated: selinux-policy-3.6.32-49.fc12.noarch
Nov 26 15:34:42 Updated: selinux-policy-targeted-3.6.32-49.fc12.noarch
Nov 26 15:34:47 Updated: system-config-printer-1.1.13-11.fc12.x86_64
Nov 26 15:34:48 Updated: 4:perl-libs-5.10.0-85.fc12.x86_64
Nov 26 15:34:49 Updated: 1:perl-Pod-Escapes-1.04-85.fc12.x86_64
Nov 26 15:35:07 Updated: 4:perl-5.10.0-85.fc12.x86_64
Nov 26 15:35:08 Updated: perl-Compress-Raw-Zlib-2.008-85.fc12.x86_64
Nov 26 15:35:09 Updated: perl-IO-Compress-Base-2.008-85.fc12.x86_64
Nov 26 15:35:10 Updated: perl-IO-Compress-Zlib-2.008-85.fc12.x86_64
Nov 26 15:35:13 Updated: perl-Test-Harness-3.16-85.fc12.x86_64
Nov 26 15:35:14 Updated: 1:perl-Pod-Simple-3.07-85.fc12.x86_64
Nov 26 15:35:15 Updated: 3:perl-version-0.74-85.fc12.x86_64
Nov 26 15:35:16 Updated: perl-Compress-Zlib-2.008-85.fc12.x86_64
Nov 26 15:35:18 Updated: 4:perl-devel-5.10.0-85.fc12.x86_64
Nov 26 15:35:20 Updated: perl-ExtUtils-MakeMaker-6.36-85.fc12.x86_64
Nov 26 15:35:22 Updated: 1:perl-ExtUtils-ParseXS-2.18-85.fc12.x86_64

Comment 10 Eric Hopper 2009-12-04 21:36:49 UTC
I still have this problem with kernel-2.6.30.9-99.fc11.x86_64

Comment 11 Eric Hopper 2009-12-31 02:43:27 UTC
I still have this problem with kernel-2.6.30.10-105.fc11.x86_64 so I'm stuck back at kernel-2.6.29.6-217.2.16.fc11.x86_64 which is the last kernel that worked.

Comment 12 Bug Zapper 2010-04-28 10:14:45 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Eric Hopper 2010-05-11 07:09:25 UTC
The Beta of Fedora 13 does not have this bug.  If the resolution is "Upgrade to a new release" then the bug can be closed.

Comment 14 Bug Zapper 2010-06-28 14:32:52 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.