Bug 521982 - KMS:R200:FireGL8800:AGP DVI-resolution,3d problems
Summary: KMS:R200:FireGL8800:AGP DVI-resolution,3d problems
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 12
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: card_R200
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-08 22:48 UTC by mark gress
Modified: 2018-04-11 07:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-16 00:15:59 UTC


Attachments (Terms of Use)
Xorg log file (38.70 KB, text/plain)
2009-10-19 11:22 UTC, mark gress
no flags Details
message file (456.31 KB, text/plain)
2009-10-20 22:40 UTC, mark gress
no flags Details
Message file (728.75 KB, text/plain)
2009-11-01 18:11 UTC, mark gress
no flags Details
var log message (837.87 KB, text/plain)
2009-11-01 18:28 UTC, mark gress
no flags Details
messages file F12 final (186.21 KB, application/octet-stream)
2009-11-28 01:46 UTC, mark gress
no flags Details
messages file F12 final nomodeset (297.55 KB, application/octet-stream)
2009-11-28 02:09 UTC, mark gress
no flags Details

Description mark gress 2009-09-08 22:48:56 UTC
Description of problem:  Cannot power LCD monitor with my firegl 8800 card.  3d rendering and switching resolutions seems to be having problems as well.


Version-Release number of selected component (if applicable): Fedora 12 alpha 1 KDE respin/live cd


How reproducible: Every time


Steps to Reproduce:
1. Boot using DVI cable - the monitor blanks after BIOS.  LCD searching for signal
2. Boot computer using VGA cable works and the computer usable
3. launch applications or click on applets(when applicable) and they won't work


Actual results: Blank screen or improper execution


Expected results: Usable desktop, usable apps/applets


Additional info:  I also have a radeon 9000 pro card I used for comparison purposes from another computer.  Using F12 alpha and the 9000 I can power/light the monitor and use the desktop.  the FireGL card will power my LCD via DVI on fedora 10.  So the cards, ports, and cables are good.

Regarding 3d issues, I tried downloading a few things for testing purposes.  Glest and BZflag refuse to start.(crash)  Kcometen4 fails to start for a screen saver, and doesn't show in the preview pane in the KDE screensaver control panel.

The 3d issue seems to affect both cards, the DVI is related just to the firegl card.

When I click on the KRandRtray applet with either card, the screen goes blank.  If I try to change resolutions in the KDE system settings "display" control panel, that also makes the screen go blank.  With either card.

Also, at installation time when reporting hardware data smolt mis-identifies the firegl card as a radeon 8500.

My monitor is a Syncmaster 204b.

Comment 1 Dave Airlie 2009-10-07 09:21:18 UTC
does the DVI work if you boot with nomodeset on kernel command line?

can you also attach an Xorg log file?

Comment 2 Jérôme Glisse 2009-10-15 14:34:08 UTC
Please test again with newer version of fedora 12, lot of fixes went in.

Comment 3 mark gress 2009-10-19 11:22:48 UTC
Created attachment 365228 [details]
Xorg log file

Here's that log file.

Comment 4 mark gress 2009-10-19 11:42:18 UTC
Dave, the DVI still does not work when I add the nomodeset to the kernel line.  KRandR control panel still blanks out my monitor when I try switching resolutions as well.

I will attach my grub file so you can see what I did just in case it's wrong.

Dave and Jerome, thanks, I fully intend in giving all this a try again when Beta 2 comes out soon.

Grub.conf follows:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/vmlinuz-version ro root=/dev/sda1
#          initrd /boot/initrd-version.img
#boot=/dev/sda
default=3
timeout=3
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31-0.125.4.2.rc5.git2.fc12.i686)
	root (hd0,0)
	kernel /boot/vmlinuz-2.6.31-0.125.4.2.rc5.git2.fc12.i686 ro root=UUID=853f6d1c-f479-40b1-8d18-8af9cc613645 rhgb quiet nomodeset LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
	initrd /boot/initrd-2.6.31-0.125.4.2.rc5.git2.fc12.i686.img

Comment 5 Jérôme Glisse 2009-10-20 10:13:36 UTC
Can you please attach dmesg when KMS on using DVI (ie when the monitor doesn't work with kms).

Comment 6 mark gress 2009-10-20 12:24:35 UTC
I don't understand your question, or I'm just not understanding how I could accomplish that.

The monitor does not light up, so I can't see what's going on.

While using VGA so that I can see what is going on, is there a command you want me to type in to initiate DVI to see what errors are created?  Can that be done?

Comment 7 Jérôme Glisse 2009-10-20 16:25:11 UTC
You need to log through ssh on the computer. If you can't do that, do the following:

-boot into kms with dvi where you have no screen
-reboot into nokms or switch to vga cable and attach /var/log/messages to this bug

Comment 8 mark gress 2009-10-20 22:39:52 UTC
Alright.  I connected the DVI, allowed the blind boot.  I restarted using CTL/ALT/DEL.

Comment 9 mark gress 2009-10-20 22:40:59 UTC
Created attachment 365438 [details]
message file

Comment 10 Jérôme Glisse 2009-10-21 15:58:59 UTC
Doesn't have what i am looking for. Please note the time at which you boot with KMS, give the kernel 3min to boot then press the power button for a short period of time (it should trigger shutdown) wait 2 minute and reboot the computer using vga. Then attach /var/log/messages and give the hour+minute at which you booted with KMS enabled.

Comment 11 mark gress 2009-11-01 18:11:11 UTC
Created attachment 367021 [details]
Message file

Here is the log file as you requested.

I started the computer on DVI blind, waited a few minutes, then held the power button for a few secs and let it shut down again.  I'm back on VGA again.

1:01 PM November 1st.

Comment 12 mark gress 2009-11-01 18:28:48 UTC
Created attachment 367022 [details]
var log message

So.... after I sent the file just a minute ago I remembered that I didn't remove the nomodeset out of the grub.conf file.

So this message file is from today at 1:13 PM without nomodeset.  The file from a few minutes ago is with nomodeset.

I followed the same procedure; boot on DVI blind, wait a few minutes, then hold in the button for a few and allow it to shut down.

Current Grub.conf:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/vmlinuz-version ro root=/dev/sda1
#          initrd /boot/initrd-version.img
#boot=/dev/sda
default=3
timeout=3
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31-0.125.4.2.rc5.git2.fc12.i686)
	root (hd0,0)
	kernel /boot/vmlinuz-2.6.31-0.125.4.2.rc5.git2.fc12.i686 ro root=UUID=853f6d1c-f479-40b1-8d18-8af9cc613645 rhgb quiet LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
	initrd /boot/initrd-2.6.31-0.125.4.2.rc5.git2.fc12.i686.img

Comment 13 Jérôme Glisse 2009-11-03 20:02:07 UTC
So to sumup monitor connected through DVI doesn't light up when with KMS but it does if you boot with KMS off right ? Please attach Xorg log of session when KMS is off and DVI is working. The issue here is that we can't get any edid on the DVI connector, my guess is that bios give us wrong i2c port or mask, what's strange is that you said F10 was working, i don't think F10 as workaround for this.

Comment 14 Matěj Cepl 2009-11-05 17:15:01 UTC
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Comment 15 Bug Zapper 2009-11-16 12:04:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 16 Dave Airlie 2009-11-24 09:25:22 UTC
any chance of a retest with F12 final?

Comment 17 Leif Gruenwoldt 2009-11-25 04:47:07 UTC
This looks like a duplicate of bug #484992

Comment 18 mark gress 2009-11-28 01:46:18 UTC
Created attachment 374336 [details]
messages file F12 final

This is from a vanilla F12(final) install.  Updates applied.

Comment 19 mark gress 2009-11-28 01:49:20 UTC
Leif, that may not be a duplicate.  That's an r4xx card, mine is an R2xx.

Plus, my DVI works fine on Fedora 10.  I can also change resolutions and a host of other things which are improper at the moment with the newer fedora version.

Comment 20 mark gress 2009-11-28 01:50:24 UTC
(In reply to comment #18)
> Created an attachment (id=374336) [details]
> messages file F12 final
> 
> This is from a vanilla F12(final) install.  Updates applied.  

Forgot to add that I tried using the DVI port at around 830 PM tonight.

Comment 21 mark gress 2009-11-28 02:09:12 UTC
Created attachment 374338 [details]
messages file F12 final nomodeset

This is different.  I added nomodeset to the kernel line in my grub.conf file and the DVI appears to be working now.  Partially anyways.

Grub now appears on screen, as does the basic fedora splash screen.(blue/light blue/white bar at the bottom of the screen)

But the desktop itself won't appear.

Also, when I pushed in the power button after a few seconds the video re appeared to tell me that shutdown was in progress.

Comment 22 mark gress 2010-01-24 04:20:19 UTC
Just did some updates, DVI still only partially working using nomodeset only.(I can see splash screen, but not desktop)  KRandR started working at some point, however.  I can change resolutions now.

Comment 23 Bug Zapper 2010-11-04 10:09:52 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 24 mark gress 2010-11-16 00:15:40 UTC
Upgraded to fedora 13 over the weekend............

All updates applied...........

DVI working great at this point.  full desktop usability.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.