This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 521989 - New Package for Dogtag PKI:pki-util
New Package for Dogtag PKI:pki-util
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks: Dogtag-to-Fedora 521996 522207
  Show dependency treegraph
 
Reported: 2009-09-08 20:52 EDT by Kevin Wright
Modified: 2015-07-13 00:56 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.3.0-5.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-07 16:42:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
dennis: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Kevin Wright 2009-09-08 20:52:08 EDT

    
Comment 1 Kevin Wright 2009-09-08 21:49:41 EDT
first pass at getting pki-util into Fedora.
Comment 2 Kevin Wright 2009-09-10 14:14:59 EDT
The pki-util.spec file can be downloaded from:

http://people.redhat.com/kwright/pki-util/pki-util.spec


The source rpm can be downloaded from:

http://people.redhat.com/kwright/pki-util/pki-util-1.3.0-1.fc11.src.rpm

Removing the NotReady flag from the Whiteboard.
Comment 3 Kevin Wright 2009-09-11 14:24:52 EDT
Dogtag is an enterprise software system designed to manage enterprise Public Key Infrastructure (PKI) deployments.

The Dogtag PKI Utility Framework is required by the following four Dogtag PKI subsystems:

    the Dogtag Certificate Authority
    the Dogtag Data Recovery Manager
    the Dogtag Online Certificate Status Protocol Manager, and
    the Dogtag Token Key Service
Comment 4 Kevin Wright 2009-10-23 22:42:28 EDT
updated spec file and src rpm:

Spec URL: http://people.redhat.com/kwright/pki-util/pki-util.spec
SRPM URL: http://people.redhat.com/kwright/pki-util/pki-util-1.3.0-1.fc11.src.rpm
Comment 5 Kevin Wright 2009-11-11 19:25:46 EST
From the changelog:

* Mon Nov 2 2009 Matthew Harmsen <mharmsen@redhat.com> 1.3.0-2
- Bugzilla Bug #521989 - packaging for Fedora Dogtag
- Take ownership of directories

Updated spec file and src rpm:

Spec URL: http://people.redhat.com/kwright/pki-util/pki-util.spec
SRPM URL:
http://people.redhat.com/kwright/pki-util/pki-util-1.3.0-2.fc11.src.rpm
Comment 6 Dennis Gilmore 2009-11-20 15:37:50 EST
from the java guidelines
Directory structure
All JAR files MUST go into %{_javadir}. Exceptions include JNI-using JAR files , and application-specific JAR files (ie. JAR files that can only reasonably be used as part of an application and therefore constitute application-private data).

Java API documentation uses a system known as javadoc. All javadocs MUST be installed into %{_javadocdir}.

I feel like the jars should be in %{_javadir} not %{_datadir}/java/pki/
 if there is a valid reason that im missing for it to be elsewhere. either way it should be using the correct %{_javadir} macros.
Comment 7 Matthew Harmsen 2009-11-23 21:54:49 EST
From the comment above:
"Exceptions include JNI-using JAR files, and application-specific JAR files (ie. JAR files that can only reasonably be used as part of an application and therefore constitute application-private data)."

Since all jars and directories under "/usr/share/java/pki/" are specific to the Dogtag application (e. g. - "pki"), are you simply asking us to change "%{_datadir}/java/pki/" to "%{_javadir}/pki/"?
Comment 8 Dennis Gilmore 2009-11-23 22:36:48 EST
im asking why should it be in %{_javadir}/pki/ and not %{_javadir}/ is there some reason the jars should not be easily available for other jars? at the least you should be using %{_javadir}/pki/ but i dont see why it should not be available for all to use.
Comment 9 Matthew Harmsen 2009-11-24 14:27:23 EST
This bug was reviewed during the daily PKI scrum meeting on November 24, 2009, and   all on the PKI team agreed that the jar files constitute application-specific data, not general-use libraries.

All of these jars constitute a PKI application consisting of four separate servers that sit on top of tomcat5, and although some of these jars have the notion of being "public" versus "private", these "public" API jars are intended to be used for development of plug-ins specific to this PKI application.

As such, while it was determined that it makes more sense for the jars to remain in their current directories, the changes from "%{_datadir}/java/pki/" to "%{_javadir}/pki/" will be made to the spec file.
Comment 10 Kevin Wright 2009-11-24 21:43:26 EST
* Tue Nov 24 2009 Matthew Harmsen <mharmsen@redhat.com> 1.3.0-3
- Bugzilla Bug #521989 - packaging for Fedora Dogtag
- Use "_javadir" macro when appropriate

Updated spec file and src rpm:

Spec URL: http://people.redhat.com/kwright/pki-util/pki-util.spec
SRPM URL:
http://people.redhat.com/kwright/pki-util/pki-util-1.3.0-3.fc11.src.rpm
Comment 11 Matthew Harmsen 2009-11-24 22:24:31 EST
Comment #9 applies to this "pki-util" package (as well as other application-specific packages such as "pki-common").

Other "top-level" packages such as "pki-ca" and "pki-java-tools" among others will move their packages to be directly under %{_javadir}.
Comment 12 Matthew Harmsen 2009-11-24 22:26:22 EST
Comment #11 should say:

Other "top-level" packages such as "pki-ca" and "pki-java-tools" among others
will move their "jars" to be directly under %{_javadir}.
Comment 13 Dennis Gilmore 2009-12-11 09:44:30 EST
It all looks good now.

there is a consistent use of macros. 
rpmlint is silent
license is ok
spec is clear and legible
source matches
sha256sum pki-util-1.3.0.tar.gz fedora/SOURCES/pki-util-1.3.0.tar.gz
512c826e870d2bf631f71d1ffeb31333936296a55c9e0892bcf0cafe5ea10319  pki-util-1.3.0.tar.gz
512c826e870d2bf631f71d1ffeb31333936296a55c9e0892bcf0cafe5ea10319  fedora/SOURCES/pki-util-1.3.0.tar.gz

approved
Comment 14 Kevin Wright 2009-12-11 13:46:04 EST
New Package CVS Request
=======================
Package Name: pki-util
Short Description: The Dogtag PKI Utility Framework is required by the following four Dogtag PKI subsystems: the Dogtag Certificate Authority, the Dogtag Data Recovery Manager, the Dogtag Online Certificate Status Protocol Manager, and     the Dogtag Token Key Service.   
Owners: kwright
Branches: F-11, F-12, EL-5
InitialCC: ausil
Comment 15 Kevin Wright 2009-12-11 16:30:30 EST
Changing the short description

New Package CVS Request
=======================
Package Name: pki-util
Short Description: The Dogtag PKI Utility Framework is required by various dogtag packages.
Owners: kwright
Branches: F-11, F-12, EL-5
InitialCC: ausil
Comment 16 Kevin Wright 2009-12-11 16:42:29 EST
Short Description: The Dogtag PKI Utility Framework
Comment 17 Kevin Fenzi 2009-12-14 12:41:24 EST
cvs done.
Comment 18 Fedora Update System 2009-12-21 16:57:10 EST
pki-util-1.3.0-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/pki-util-1.3.0-4.fc11
Comment 19 Fedora Update System 2009-12-21 17:40:54 EST
pki-util-1.3.0-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pki-util-1.3.0-4.fc12
Comment 20 Fedora Update System 2009-12-21 22:35:09 EST
pki-util-1.3.0-4.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/pki-util-1.3.0-4.el5
Comment 21 Fedora Update System 2009-12-22 16:57:51 EST
pki-util-1.3.0-4.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pki-util'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-1044
Comment 22 Fedora Update System 2009-12-24 15:38:02 EST
pki-util-1.3.0-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pki-util'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-13624
Comment 23 Fedora Update System 2009-12-24 15:40:43 EST
pki-util-1.3.0-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pki-util'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13650
Comment 24 Fedora Update System 2010-01-07 16:42:01 EST
pki-util-1.3.0-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2010-01-12 18:40:16 EST
pki-util-1.3.0-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2010-01-12 18:48:17 EST
pki-util-1.3.0-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2010-01-25 23:00:25 EST
pki-util-1.3.0-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/pki-util-1.3.0-5.fc11
Comment 28 Fedora Update System 2010-01-25 23:10:46 EST
pki-util-1.3.0-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pki-util-1.3.0-5.fc12
Comment 29 Fedora Update System 2010-01-25 23:16:51 EST
pki-util-1.3.0-5.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/pki-util-1.3.0-5.el5
Comment 30 Fedora Update System 2010-02-11 23:44:46 EST
pki-util-1.3.0-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 31 Fedora Update System 2010-02-11 23:47:19 EST
pki-util-1.3.0-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2010-02-17 11:57:50 EST
pki-util-1.3.0-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.