Bug 521993 - New Package for Dogtag PKI:pki-setup
New Package for Dogtag PKI:pki-setup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Extras Quality Assurance
:
Depends On:
Blocks: Dogtag-to-Fedora
  Show dependency treegraph
 
Reported: 2009-09-08 21:53 EDT by Kevin Wright
Modified: 2015-07-13 00:56 EDT (History)
10 users (show)

See Also:
Fixed In Version: pki-setup-1.3.3-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 18:43:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+
dennis: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Kevin Wright 2009-09-08 21:53:11 EDT
first pass at getting pki-setup into Fedora.
Comment 1 Kevin Wright 2009-09-10 14:32:06 EDT
The spec file can be downloaded from:

http://people.redhat.com/kwright/pki-setup/pki-setup.spec

The source rpm can be downloaded from:

http://people.redhat.com/kwright/pki-setup/pki-setup-1.3.0-1.fc11.src.rpm

Removing the NotReady flag from the Whiteboard.
Comment 2 Kevin Wright 2009-09-11 14:28:43 EDT
Description:

Public Key Infrastructure (PKI) setup scripts used to create and remove instances from Dogtag PKI deployments.
Comment 4 Parag AN(पराग) 2009-12-10 05:33:24 EST
1) you don't need any perl packages as Requires, you can safely remove them as yum will auto installs them.

2) After removing those perl requires when I try to install package I see pkiperl file is needed by this package. May I know which package is supposed to provide pkiperl file?

3) why not to choose following as Group?
Group:          System Environment/Base
Comment 5 Parag AN(पराग) 2009-12-15 03:30:39 EST
please update this package for review
Comment 6 Kevin Wright 2009-12-15 14:35:01 EST
This package is not currently ready. (see whiteboard)
Will update as soon as the code has been updated.
Comment 7 Kevin Wright 2009-12-19 19:39:28 EST
* Mon Dec 14 2009 Matthew Harmsen <mharmsen@redhat.com> 1.3.0-5
- Bugzilla Bug #521993 - packaging for Fedora Dogtag
- Bugzilla Bug #529070 -  rpm packaging problems (cannot reinstall correctly)
- Removed 'with exceptions' from License
- Removed 'Requires: perl >= 5.8.0'

updated spec file and src rpm:

Spec URL: http://people.redhat.com/kwright/pki-setup/pki-setup.spec

SRPM URL: http://people.redhat.com/kwright/pki-setup/pki-setup-1.3.0-5.fc11.src.rpm  

removed NotReady from the whiteboard.
Comment 8 Kevin Wright 2009-12-19 19:44:31 EST
Regarding the issues from Comment #4

* "BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)" is provided because this package must also be made into an EPEL package

* "BuildRequires:  ant" is the ONLY BuildRequires in this package, so it cannot be removed unless it is replace by something more appropriate

* Several packages may own the "%{_datadir}/pki/" directory, since there are multiple subdirectories (some owned solely by one package) underneath this common directory -- see https://fedoraproject.org/wiki/Packaging/Guidelines#File_and_Directory_Ownership
Comment 9 Parag AN(पराग) 2009-12-20 23:02:38 EST
Review:
+ package builds in mock (rawhide i686).
koji Build =>http://koji.fedoraproject.org/koji/taskinfo?taskID=1882524
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url (sha1sum)
9d363872b283edbd8d719ccb11fd952e8a496482  pki-setup-1.3.0.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ no scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Not a GUI application


Suggestions:
1) As said in comment#4, please remove Requires for perl packages. perl dependencies are auto installed by yum.

2) May I know why this package have "Requires: pki-native-tools" ?
Comment 10 Kevin Wright 2009-12-23 03:58:22 EST
removed all Requires for perl packages.

updated spec file and src rpm:

Spec URL: http://people.redhat.com/kwright/pki-setup/pki-setup.spec

SRPM URL:
http://people.redhat.com/kwright/pki-setup/pki-setup-1.3.0-6.fc11.src.rpm
Comment 11 Parag AN(पराग) 2009-12-23 05:12:26 EST
Thanks.

Koji build:-http://koji.fedoraproject.org/koji/taskinfo?taskID=1887911

As issue2 in above comment is not blocking this review. I will approve this package.

APPROVED.
Comment 12 Kevin Wright 2009-12-23 12:31:13 EST
New Package CVS Request
=======================
Package Name: pki-setup
Short Description: The Dogtag PKI Setup Framework 
Owners: kwright
Branches: F-11, F-12, EL-5
InitialCC: ausil
Comment 13 Dennis Gilmore 2009-12-23 14:50:34 EST
CVS Done
Comment 14 Fedora Update System 2009-12-23 16:15:24 EST
pki-setup-1.3.0-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/pki-setup-1.3.0-6.fc11
Comment 15 Fedora Update System 2009-12-23 16:16:50 EST
pki-setup-1.3.0-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pki-setup-1.3.0-6.fc12
Comment 16 Fedora Update System 2009-12-24 15:36:27 EST
pki-setup-1.3.0-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pki-setup'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-13613
Comment 17 Fedora Update System 2009-12-24 15:39:33 EST
pki-setup-1.3.0-6.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pki-setup'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13639
Comment 18 Fedora Update System 2010-01-12 18:43:19 EST
pki-setup-1.3.0-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2010-01-12 18:50:01 EST
pki-setup-1.3.0-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2010-01-21 20:13:04 EST
pki-setup-1.3.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/pki-setup-1.3.2-1.fc11
Comment 21 Fedora Update System 2010-01-21 20:24:54 EST
pki-setup-1.3.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pki-setup-1.3.2-1.fc12
Comment 22 Fedora Update System 2010-02-02 14:35:18 EST
pki-setup-1.3.3-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/pki-setup-1.3.3-2.fc11
Comment 23 Fedora Update System 2010-02-02 14:48:43 EST
pki-setup-1.3.3-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pki-setup-1.3.3-2.fc12
Comment 24 Fedora Update System 2010-02-23 00:26:23 EST
pki-setup-1.3.3-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2010-02-23 00:34:21 EST
pki-setup-1.3.3-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.