Bug 522018 - configure-proxy.sh --non-interactive should not ask for user interaction
Summary: configure-proxy.sh --non-interactive should not ask for user interaction
Keywords:
Status: CLOSED DUPLICATE of bug 516296
Alias: None
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer
Version: 530
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On: 500151
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2009-09-09 07:04 UTC by Miroslav Suchý
Modified: 2009-09-17 07:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 500151
Environment:
Last Closed: 2009-09-17 07:48:03 UTC


Attachments (Terms of Use)

Description Miroslav Suchý 2009-09-09 07:04:09 UTC
+++ This bug was initially created as a clone of Bug #500151 +++

Description of problem:
configure-proxy.sh --non-interactive asks for user interaction.

Version-Release number of selected component (if applicable):
spacewalk-proxy-installer-0.5.25-4.el5sat

How reproducible:
always

Steps to Reproduce:
1. install new system
2. register in to webqa
3. /usr/sbin/configure-proxy.sh --answer-file=proxy-answer.txt --non-interactive
  
Actual results:
Proxy version to activate [5.3]: 5.3
RHN Parent [xmlrpc.rhn.webqa.redhat.com]: xmlrpc.rhn.webqa.redhat.com
Traceback email [michael.mraka@redhat.com]: michael.mraka@redhat.com
Use SSL [Y]: Y
CA Chain [/usr/share/rhn/RHNS-CA-CERT]: /usr/share/rhn/RHNS-CA-CERT
Please do copy your CA key and public certificate from xmlrpc.rhn.webqa.redhat.com to 
/root/ssl-build directory. You may want to execute this command:
 scp 'root@xmlrpc.rhn.webqa.redhat.com:/root/ssl-build/RHN-ORG-{PRIVATE-SSL-KEY,TRUSTED-SSL-CERT}' /root/ssl-build


Expected results:
succesful non-interactive installation

Additional info:

...

--- Additional comment from jpazdziora@redhat.com on 2009-09-09 02:23:41 EDT ---

Hmmm, ough.

When I have

POPULATE_CONFIG_CHANNEL="y"

in my answer file, the

/usr/sbin/configure-proxy.sh --answer-file=/tmp/proxy-answer.txt --non-interactive

command actually stops waiting for interactive prompt:

Configuring monitoring.
Monitoring parent [xen62.englab.brq.redhat.com]: xen62.englab.brq.redhat.com
Monitoring parent IP [10.34.34.62]: 10.34.34.62
Enable monitoring scout [Y/n]: Y/n
Using CA key at /root/ssl-build/RHN-ORG-PRIVATE-SSL-KEY.
Generating distributable RPM for CA public certificate:
Copying CA public certificate to /var/www/html/pub for distribution to clients:
Generating SSL key and public certificate:
Installing SSL certificate for Apache and Jabberd:
Preparing packages for installation...
rhn-org-httpd-ssl-key-pair-vmware139.englab.brq-1.0-1
Create and populate configuration channel rhn_proxy_config_1000010146? [y]: y
Using server name xen62.englab.brq.redhat.com
Red Hat Network username: 

instead of either proceeding or failing. So this bugzilla is not fully fixed. Adding it to sat600-triage. Please decide if we will address this as part of this bug, or whether I should file a new one.

Comment 1 Miroslav Suchý 2009-09-09 07:06:27 UTC
Cloned. We will need to enhance to rhncfg-manager to accept username and password on command line and then proxy installer to pass this parameters to rhncfg-manager.

Comment 2 Miroslav Suchý 2009-09-17 07:48:03 UTC

*** This bug has been marked as a duplicate of bug 516296 ***


Note You need to log in before you can comment on or make changes to this bug.