Bug 522025 - Updating to 2.6.30 lets kernel panic on starx
Summary: Updating to 2.6.30 lets kernel panic on starx
Keywords:
Status: CLOSED DUPLICATE of bug 521574
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 07:29 UTC by Felix Möller
Modified: 2009-09-09 18:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-09 18:39:04 UTC


Attachments (Terms of Use)

Description Felix Möller 2009-09-09 07:29:38 UTC
Description of problem:
I am using the update-testing repo. Which contains the 2.6.30 kernel series.

Updating to a 2.6.30 kernel prevents me to start Xorg. 

Booting in to init 3 and then entering startx manually gives me a blinking Caps Lock.

This is about a Thinkpad T400 running 32bit userland with 4GB RAM.

# lspci
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.30.5-43.fc11.i686 is broken
kernel-PAE-2.6.29.6-217.2.8.fc11.i686 does work
xorg-x11-drv-intel-2.7.0-7.fc11.i586
xorg-x11-server-common-1.6.3-4.fc11.i586

How reproducible:
allways

Steps to Reproduce:
1. start the computer 
2. wait
  
Actual results:
crash

Expected results:
gdm

Comment 1 Jason Montleon 2009-09-09 18:13:56 UTC
I just experienced this as well on a Lenovo x61. It appears to be related to the new PAE kernel.

kernel-PAE-2.6.29.6-217.2.16.fc11.i686 works. 
kernel-2.6.30.5-43.fc11.i686 works.
kernel-PAE-2.6.30.5-43.fc11.i686 does not work. 

# rpm -q kernel && rpm -q kernel-PAE && rpm -q xorg-x11-drv-intel
kernel-2.6.30.5-43.fc11.i586
kernel-PAE-2.6.29.6-217.2.16.fc11.i686
kernel-PAE-2.6.30.5-43.fc11.i686
kernel-PAE-2.6.29.6-217.2.8.fc11.i686
xorg-x11-drv-intel-2.7.0-7.fc11.i586

As the original comment states, either booting into run level 5 or running startx causes a kernel panic when the x server starts.

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
        Subsystem: Lenovo T61
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Region 0: Memory at f8200000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: [d0] Power Management version 3
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
                Bridge: PM- B3+

Comment 2 Jason Montleon 2009-09-09 18:39:04 UTC

*** This bug has been marked as a duplicate of bug 521574 ***


Note You need to log in before you can comment on or make changes to this bug.