Bug 52204 - fat32 OS on hda4 not availible on boot menu
fat32 OS on hda4 not availible on boot menu
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 14:00 EDT by Joshua Jensen
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-22 14:45:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2001-08-21 14:00:15 EDT
Description of Problem:

On my laptop, hda4 is a fat32 win2000 partition.  The RC1 installer simply
doesn't give me a list of boot menu selections that includes the DOS
partition.  Having said this, on another machine the RC1 installer *does*
recognize my win2000 fat32 hda1 partition.  I wonder if there is a bug
(feature?) that only detects dos partitions (that should be added to the
bootable list) on the first primary partition?

Version-Release number of selected component (if applicable):

RC1


Thanks,

Joshua Jensen
Comment 1 Jeremy Katz 2001-08-21 17:18:03 EDT
Were there any other DOS partitions on this machine?  

If not, could you try installing the anaconda package and running the following
as root:
`PYTHONPATH="/usr/lib/anaconda:/usr/lib/anaconda/isys:/usr/lib/anaconda/balkan"
python -c "import isys; print isys.checkBoot('/dev/hda4')"`

and let me know whether it gives a 0 or a 1
Comment 2 Joshua Jensen 2001-08-22 14:30:11 EDT
Ok... here is what it says:

[root@mule root]# 
`PYTHONPATH="/usr/lib/anaconda:/usr/lib/anaconda/isys:/usr/lib/anaconda/balkan" 
python -c "import isys; print isys.checkBoot('/dev/hda4')"`
bash: 1: command not found
[root@mule root]#

[root@mule root]# fdisk -l /dev/hda
 
Disk /dev/hda: 240 heads, 63 sectors, 2343 cylinders
Units = cylinders of 15120 * 512 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1         2     15088+  83  Linux
/dev/hda2             3        36    257040   82  Linux swap
/dev/hda3            37       343   2320920   83  Linux
/dev/hda4   *       344      2343  15120000    b  Win95 FAT32


Joshua
Comment 3 Joshua Jensen 2001-08-22 14:45:08 EDT
Before I ran that fdisk command, I had to change the type of hda4 from 83 to a 
Fat32 type of "b".  This must have been my partitioning error during 
install... however, the output of the python command didn't change... it said, 
and still says, "1".

I imagine, but don't know, that the partition type is used to determine the 
"boot label menu" list during install... this "bug" may very well be _me_.

Joshua

Comment 4 Jeremy Katz 2001-08-22 15:44:26 EDT
That's it... we only add DOS to the menu if the filesystem is FAT and if it's
bootable (which is what the python command checked).  If not, then we don't try
to boot it.  

Sort of not a bug, sort of a "well, it would be nice if we really did this" but
it would require completely redoing the boot loader screens which isn't
happening (at least not yet :)

Note You need to log in before you can comment on or make changes to this bug.