Bug 52207 - Xconfigurator has duplicate entries
Summary: Xconfigurator has duplicate entries
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-21 18:28 UTC by Joshua Jensen
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-21 20:30:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2001-08-21 18:28:23 UTC
Description of Problem:

The installer and Xconfigurator duplicates some Philips monitors:

Xconfigurator --listmonitors 2> /dev/null | grep -i bril
			Philips Brilliance 105(15inch/CM2200)
			Philips Brilliance 107(17inch/CM8800)
			Philips Brilliance 107(PRODUCT ID 17A58...)
			Philips Brilliance 109(PRODUCT ID 19A58...)
			Philips Brilliance 201(21inch/CM1700)
			Philips Brilliance 201CS
			Philips Brilliance AX4500(14.5 LCD MONITOR)
			Philips BRILLIANCE 105(15inch/CM2200)
			Philips BRILLIANCE 107(17inch/CM8800)
			Philips BRILLIANCE 107(PRODUCT ID 17A58...)
			Philips BRILLIANCE 109(PRODUCT ID 19A58...)
			Philips BRILLIANCE 201(21inch/CM1700)
			Philips BRILLIANCE AX4500(14.5 LCD MONITOR)


So I have a BRILLIANCE 109, which do I pick?  There seems to be no
differentiation between any two similar entries... I vote for de-dupe'ing
the list so as to not confuse people.

I'm not sure if this is an installer bug, or just and Xconfigurator bug,
but it should be fixed both places.  I originally noted this problem in the
GUI installer.


Upon further investigation, I see many overlaps:

Xconfigurator --listmonitors 2> /dev/null | sort -f | uniq -iD
Xconfigurator --listcards 2> /dev/null | sort -f | uniq -iD


Version-Release number of selected component (if applicable):

RC1


Thanks,

Joshua Jensen

Comment 1 Glen Foster 2001-08-21 20:30:32 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 2 Mike A. Harris 2001-08-21 20:44:05 UTC
Fixed in CVS, will appear in rawhide soon.  I fixed it before it
was flagged SHOULD fix, but it really wasn't something I would have
considered a SHOULD-FIX myself..  I just had MonitorsDB open already.

;o)


Note You need to log in before you can comment on or make changes to this bug.