Bug 522078 - avahi initscript lsb compliance
Summary: avahi initscript lsb compliance
Keywords:
Status: CLOSED DUPLICATE of bug 600430
Alias: None
Product: Fedora
Classification: Fedora
Component: avahi
Version: 12
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: InitScriptsProject
TreeView+ depends on / blocked
 
Reported: 2009-09-09 12:32 UTC by Matěj Šusta
Modified: 2010-06-25 01:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-25 01:45:03 UTC


Attachments (Terms of Use)

Description Matěj Šusta 2009-09-09 12:32:57 UTC
Description of problem:
avahi initscript is not LSB compliant

Version-Release number of selected component (if applicable):
avahi-0.6.25-3.fc11.i586

Start of already started avahi
1. service avahi-daemon status || service avahi-daemon start
2. service avahi-daemon start && echo "LSB compliance: OK"
... same applies to stop of already stopped daemon - request for start / stop is returning error with exitcode 255, which is wrong.
Should return 0.

Status on stopped avahi:
1. service avahi-daemon status && service avahi-daemon stop
2. service avahi-daemon status
3. echo $?
... is returning 1, which is wrong (service dead and pid file exists).
Should return 3, program is not running.

Status on stopped avahi with /var/lock/subsys/avahi-daemon present:
[root@hostel-280 ~]# touch /var/lock/subsys/avahi-daemon
[root@hostel-280 ~]# service avahi-daemon status
Avahi daemon is not running
[root@hostel-280 ~]# echo $?
1
Wrong, should return 2.

Undocumented feature reload:
[root@hostel-280 /]# service avahi-daemon
Usage: /etc/init.d/avahi-daemon {start|stop|status|restart|condrestart}
[root@hostel-280 /]# service avahi-daemon reload
Reloading Avahi daemon...                                  [  OK  ]
[root@hostel-280 /]# echo $?
0

Also, force-reload is not supported, which should be.

Comment 1 Matthias Clasen 2009-09-10 17:03:56 UTC
Do you have a patch ?

Comment 2 Matěj Šusta 2009-09-15 12:43:04 UTC
No and I can't promise that I'll have time to work on it.

Comment 4 Yulia Kopkova 2009-10-07 09:41:21 UTC
Tony, there is one more thing that needs to be fixed:

init script should also return code "4" if restarting service under
nonprivileged user:

su testuserqa -c "service $SERVICE restart"; echo $?
now: 255 
expected: 4

Comment 5 Bug Zapper 2009-11-16 12:05:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Lennart Poettering 2010-06-25 01:45:03 UTC

*** This bug has been marked as a duplicate of bug 600430 ***


Note You need to log in before you can comment on or make changes to this bug.