Bug 522139 - Does not list discovered printers when run as non-root user
Summary: Does not list discovered printers when run as non-root user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 15:03 UTC by James Ettle
Modified: 2009-10-09 03:34 UTC (History)
2 users (show)

Fixed In Version: 1.1.13-3.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-09 03:34:28 UTC


Attachments (Terms of Use)

Description James Ettle 2009-09-09 15:03:59 UTC
Description of problem:
system-config-printer doesn't display dnssd-discovered printers in the New Printer wizard when run as an ordinary user.

Running system-config-printer --debug:

Connected as user james
refresh
Created subscription 144
<monitor.Monitor instance at 0x1b705f0>: printers and jobs lists provided
update_jobs
Authentication pass: 1
Authentication: password callback set
Authentication pass: 1
Authentication: password callback set
Authentication pass: 1
Authentication: password callback set
get_notifications
update_jobs
Calling <bound method NewPrinterGUI.fetchDevices of <__main__.NewPrinterGUI instance at 0x1b5d518>>
fetchDevices
Caught exception 'module' object has no attribute 'WITH_POLKIT_1'
queryPPDs
Lock acquired for PPDs thread
Connecting (PPDs)
Fetching PPDs
PPDs thread started
Caught non-fatal exception.  Traceback:
File "/usr/share/system-config-printer/system-config-printer.py", line 5022, in got_devices
    raise exception
AttributeError: 'module' object has no attribute 'WITH_POLKIT_1'
Continuing anyway..
Closing connection (PPDs)
Releasing PPDs lock
Command canceled
Canceled subscription 144
<monitor.Monitor instance at 0x1b705f0> exited


Version-Release number of selected component (if applicable):
avahi-0.6.25-3.fc11.x86_64
system-config-printer-1.1.12-8.fc11.x86_64
PolicyKit-0.9-6.fc11.x86_64
cups-1.4.0-2.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Open s-c-p as an ordinary user.
2. Click on new.
3. Wait for discovered printers.
  
Actual results:
No discovered printers, except when run as root.

Expected results:
Discovered printers.

Comment 1 Tim Waugh 2009-09-14 13:51:07 UTC
What does 'rpm -V system-config-printer' say?

Comment 2 Tim Waugh 2009-09-14 13:53:26 UTC
Oh, never mind, I see the problem.

Comment 3 James Ettle 2009-09-14 15:45:56 UTC
OK, with system-config-printer-1.1.13-1.fc11.x86_64 I now observe a prompt for a root password. The list of discoveries shows up after supplying this password.

Comment 4 Fedora Update System 2009-09-15 07:49:43 UTC
system-config-printer-1.1.13-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8108

Comment 5 James Ettle 2009-09-15 08:04:03 UTC
Tim, is what I described in Comment #3 the *intended* behaviour?

Comment 6 Tim Waugh 2009-09-15 09:18:13 UTC
Yes.

Comment 7 Fedora Update System 2009-09-24 05:08:42 UTC
system-config-printer-1.1.13-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8108

Comment 8 Fedora Update System 2009-10-03 19:10:25 UTC
system-config-printer-1.1.13-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8108

Comment 9 Fedora Update System 2009-10-09 03:32:54 UTC
system-config-printer-1.1.13-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.