Bug 522142 - Creation of filesystem never finishes
Summary: Creation of filesystem never finishes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 15:13 UTC by Jeff Moyer
Modified: 2009-10-07 23:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-07 23:58:09 UTC


Attachments (Terms of Use)

Description Jeff Moyer 2009-09-09 15:13:21 UTC
Description of problem:

Running anaconda 12.15, the redhat system installer - please wait.
Running pre-installation scripts
Finding storage devices
Creating filesystem on /dev/sda2
In progress


Version-Release number of selected component (if applicable):
RHEL6.0-20090904.5

How reproducible:
Reproduced on 4 machines.

Comment 2 Chris Lumens 2009-09-09 15:17:19 UTC
Is there a very long lived lvm pvcreate process?

Comment 5 RHEL Product and Program Management 2009-09-09 15:45:56 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 6 Chris Lumens 2009-09-10 17:50:23 UTC
All the non-ppc test cases say the last thing they did was attempt to make the filesystem on sda1, and the ppc test case says the same with sda2.  In both cases, this is going to be the /boot filesystem since you're just doing autopart.  This pretty much rules out any LVM weirdness.

I don't really have any more helpful information to add that might narrow this down.  The only times I've seen random hangups happen in this area is because of an infinite loop in lvm.  If we can somehow get to the console to debug this while it's occurring, that'd be helpful.  Are these machines able to be reserved for use interactively?

Comment 8 Chris Lumens 2009-10-07 22:57:44 UTC
I don't really have anything helpful to add.  However, this bug was originally reported with anaconda-12.15.  We're now up to anaconda-12.30something.  Are you still seeing this problem?

Comment 9 Jeff Moyer 2009-10-07 23:58:09 UTC
I just checked the tests run for one of the systems exhibiting this problem and it appears to be resolved there.  If this is still an issue, I'm sure I'll run into it again.  For now, /i think it's OK to close this bug.


Note You need to log in before you can comment on or make changes to this bug.