Bug 522170 - ...Preferred browser->Check now->Yes doesn't work in kde
Summary: ...Preferred browser->Check now->Yes doesn't work in kde
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 16:18 UTC by Robin Green
Modified: 2010-08-20 11:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-20 11:55:52 UTC


Attachments (Terms of Use)

Description Robin Green 2009-09-09 16:18:38 UTC
Description of problem:
xdg-open does not use the user's preferred application for opening URLs, contrary to the man page. It simply assumes that if the user is using KDE, Konqueror must be preferred.

Version-Release number of selected component (if applicable):
xdg-utils-1.0.2-10.20090824cvs.fc12.noarch


How reproducible:
Always

Steps to Reproduce:
1. In Firefox, Edit->Preferences->Advanced->Preferred browser->Check now->Yes
2. xdg-open  'http://www.google.co.uk/' (in KDE)
  
Actual results:
Konqueror

Expected results:
Firefox

Additional info:

Comment 1 Rex Dieter 2009-09-09 16:54:34 UTC
This works for me:

to set preferred browser in kde,
systemsettings->default applications->web browser, 
in the following browser: firefox

xdg-open http://www.google.co.uk/

launched firefox.

Perhaps, firefox's Preferred browser->Check now->Yes preference doesn't do the right thing in kde, should be something equivalent to:

kwriteconfig --file kdeglobals --group General --key BrowserApplication '!firefox'

Comment 2 Bug Zapper 2009-11-16 12:07:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Robin Green 2010-08-20 11:55:52 UTC
No longer an issue in Fedora 13, since this Firefox feature has disappeared.


Note You need to log in before you can comment on or make changes to this bug.