Bug 522175 - yum update nVidia version not the same as kernel version
Summary: yum update nVidia version not the same as kernel version
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-updatesd
Version: 11
Hardware: i586
OS: Linux
low
medium
Target Milestone: ---
Assignee: James Antill
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 16:39 UTC by Gaston Verhulst
Modified: 2009-12-04 01:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-04 01:42:34 UTC


Attachments (Terms of Use)

Description Gaston Verhulst 2009-09-09 16:39:22 UTC
Description of problem:
Hello,
Receiving new update packages for a new kernel and a new nvidia driver, I see that the version numbers, especially the last one for kmod-nvidia,are not the same 2.0.30.5-43:
---> Package kernel.i586 0:2.6.30.5-43.fc11 set to be installed
---> Package kernel-firmware.noarch 0:2.6.30.5-43.fc11 set to be updated
---> Package kernel-headers.i586 0:2.6.30.5-43.fc11 set to be updated
---> Package kmod-nvidia-173xx.i586 0:173.14.20-1.fc11 set to be updated
---> Package kmod-nvidia-173xx-2.6.29.6-217.2.16.fc11.i586.i586 0:173.14.20-1.fc11 set to be updated
To start Fedora successfully, the kernel and kmod-nvidia have to be the same version.
E.g. now I have:
[gastonv@d515202bf ~]$ yum list installed | grep kernel
kernel.i586                             2.6.29.6-217.2.16.fc11         @updates 
kernel-firmware.noarch                  2.6.29.6-217.2.16.fc11         @updates 
kernel-headers.i586                     2.6.29.6-217.2.16.fc11         @updates
[gastonv@d515202bf ~]$ yum list installed | grep kmod-nvidia
kmod-nvidia-173xx.i586                  173.14.18-2.fc11.17            @rpmfusion-nonfree-updates
kmod-nvidia-173xx-2.6.29.6-217.2.16.fc11.i586.i586
Awaiting for a newer kmod-nvidia package and/or a new kernel, I don't make the update.
Thanks in advance for any answer,
Greetings,
Gaston Verhulst.

Comment 1 Gaston Verhulst 2009-09-10 08:48:42 UTC
Hello,
This morning, I saw there was a new kmod-nvidia for the new kernel.
So, I could safely make the new kernel and nvidia update.
The could successfully restart the system.
I am very happy that I can say that the problem is solved.
Many greetings,
Gaston Verhulst.

Comment 2 Juan P. Daza P. 2009-12-04 01:42:34 UTC
This is due to a time difference between the kernel release in the fedora repository and the package kmod-nvidia provided by rpmfusion repository.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.