This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 522182 - While doing the fastuser switching test the X window locked up
While doing the fastuser switching test the X window locked up
Status: CLOSED DUPLICATE of bug 512944
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-09 13:09 EDT by Bruno Wolff III
Modified: 2009-10-21 13:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 13:36:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (55.31 KB, text/plain)
2009-09-09 13:10 EDT, Bruno Wolff III
no flags Details
glxinfo output (15.46 KB, text/plain)
2009-09-09 13:10 EDT, Bruno Wolff III
no flags Details
Xorg.0.log (60.88 KB, text/plain)
2009-09-16 16:37 EDT, Bruno Wolff III
no flags Details
Xorg.1.log (55.83 KB, text/plain)
2009-09-16 16:38 EDT, Bruno Wolff III
no flags Details
Xorg.2.log (47.13 KB, text/plain)
2009-09-16 16:38 EDT, Bruno Wolff III
no flags Details
Xorg.0.log from nouveau sysem (27.87 KB, text/plain)
2009-09-19 16:19 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2009-09-09 13:09:37 EDT
Description of problem:
While doing the fastuser switching test and going back and forth a couple of times, I saw a white block where the list of users should have been and moving the mouse no longer caused a visible response. I was able to switch to a vt and restart X using telinit.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.x86_64

How reproducible:
Unknown, but it didn't happen until I tried switching several times.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
http://www.smolts.org/client/show/pub_9d4c50d1-47e6-4d56-9199-9260fd00720e
Comment 1 Bruno Wolff III 2009-09-09 13:10:17 EDT
Created attachment 360283 [details]
Xorg.0.log
Comment 2 Bruno Wolff III 2009-09-09 13:10:44 EDT
Created attachment 360284 [details]
glxinfo output
Comment 3 Adam Williamson 2009-09-16 14:22:47 EDT
could we get Xorg.0.log from *after* reproducing the problem but before restarting X? thanks. (or let me know if that's what the current Xorg.0.log attachment is.)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Bruno Wolff III 2009-09-16 16:37:34 EDT
Created attachment 361369 [details]
Xorg.0.log

I repeated the issue and copied over the xorg.?.log files before restarting X to the live user account. There were three of them, so I am going to upload all 3.
Comment 5 Bruno Wolff III 2009-09-16 16:38:07 EDT
Created attachment 361370 [details]
Xorg.1.log
Comment 6 Bruno Wolff III 2009-09-16 16:38:49 EDT
Created attachment 361372 [details]
Xorg.2.log
Comment 7 Adam Williamson 2009-09-17 15:26:56 EDT
hmm, not much there :/ probably going to need some more diagnostics, but i'm not sure what, so assigning.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Bruno Wolff III 2009-09-19 16:19:39 EDT
Created attachment 361782 [details]
Xorg.0.log from nouveau sysem

I saw the same thing on a machine using the nouveau driver.
http://www.smolts.org/client/show/pub_9915137d-5ecc-4aae-bda9-17366f207a68
One other note is that the cursor pointer moved with the mouse and changed depending on whether or not the cursor was on the white area that the user list would normally have been (there is had a moving blue thing) or over the background image (there it was static).
Comment 9 Adam Williamson 2009-10-21 13:36:51 EDT
we've been investigating this in the blocker bug review meeting this morning. it seems there are many reports of this type across multiple types of video hardware. closing all reports as dupes of 512944, which is the earliest report. 512944 will be marked as a release blocker.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 512944 ***

Note You need to log in before you can comment on or make changes to this bug.