Bug 522183 (Alexander, Godumov) - Fprint does not work for root user with 0483:2016 SGS Thomson Microelectronics Fingerprint Reader
Summary: Fprint does not work for root user with 0483:2016 SGS Thomson Microelectronic...
Keywords:
Status: CLOSED WONTFIX
Alias: Alexander, Godumov
Product: Fedora
Classification: Fedora
Component: libfprint
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 17:13 UTC by Alexander Godumov
Modified: 2013-04-20 07:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:33:31 UTC


Attachments (Terms of Use)

Description Alexander Godumov 2009-09-09 17:13:11 UTC
Description of problem:

I have a 0483:2016 SGS Thomson Microelectronics Fingerprint Reader on my Thinkpad T61. I have installed Fedora 11 x86_64 on this laptop and updated the system. Besides updating i have not done anything with the system. Fprint works with my normal user account however it does not work with the root account. Symptoms of the problem are:
1. GNOME`s cpu frequency scaling applet no longer works after i have set up the fingerprint reader for the root user. In its normal behaviour it asks for the root password before it changes the performance profile (default is on demand and i am trying to change it to performance). After i have set up finger print reader when i try to change the performance profile nothing happens - the dialog that prompts for the root password does not apper.
2. GNOME`s packagekit GUI is broken - it works as expected until the window that prompts for the root password should appear. In its normal behaviour i can start the program, search for packages, mark them for installation and the program can resolve the desired package`s dependencies. However when i click on the "Install" button which should supposedly bring the root password prompt the program hangs up and after several minutes crashes.
3. In system-config-services - whenever i try to do something that requires root privileges the action fails without error message. For example the program is supposed to start without asking for root password and to ask for the root password when i actually try to stop or start a service. Normally this is what happens. However after i enable the fingerprint reader for the root account it never asks for root password and the action fails without error.
4. The terminal programs do not seem to be affected - for example i can gain root access or yum even after i have configured the fingerprint reader.

For my normal account i configured the fingerprint reader using gnome-about-me and it seems to work fine. For the root user i tried first running gnome-about-me with super user privileges and then i tried running fprintd-enroll with root privileges. Both attempts resulted in the above mentioned symptoms. If i disable the fingerprint authentication for the root user i no longer experience the above mentioned problems and everything seems to work fine.

Version-Release number of selected component (if applicable):

libfprint-0.1.0-7.pre2.fc11.1

How reproducible:


Steps to Reproduce:
1.Start system-config-authentication and then checking "Enable Fingerprint Reader Support" in the Authentication tab.
2. Run gnome-about-me with root privileges or run fprintd-enroll. Enroll the finger 3 times as asked and enable the fingerprint authentication for the root user.
3. After disabling the fingerprint authentication for the root user the problems disappear and the system works as expected.
  
Actual results:
Unable to gain root access in GUI. The symptom is visible in programs with GUI like system-config-services.

Expected results:
Should be able to gain root access.

Additional info:

Comment 1 Bug Zapper 2010-04-28 10:15:22 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Bug Zapper 2010-06-28 14:33:31 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.