Bug 52225 - ifup-ippp doenst check return code of isdnctrl
Summary: ifup-ippp doenst check return code of isdnctrl
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-21 19:51 UTC by Ronny Buchmann
Modified: 2014-03-17 02:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-22 05:55:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ronny Buchmann 2001-08-21 19:51:36 UTC
Description of Problem:
/etc/init.d/network
shows succesfull started ippp device, but it isnt started at all

Version-Release number of selected component (if applicable):
initscripts-6.17-1

How Reproducible:
always

Steps to Reproduce:
i.e. use isdn4k-utils-3.1-44
or produce any other hardware problem so that isdnctrl doesnt work as expected


Expected Results:
/etc/init.d/network should show a failure not success

i think the problem is inside ifup-ippp (and ifup maybe)

possible solution:
do a final "isdnctrl list $DEVICE" to see if interface is up (maybe enough)
or do 

isdnctrl $* >/dev/null 2>&1 && exit 1

in log_isdnctrl()


btw, ibod should be started with daemon(), or not?

Comment 1 Bill Nottingham 2001-08-21 20:51:26 UTC
Than, is this fixed in 6.24-1?

Comment 2 Ronny Buchmann 2001-08-22 05:55:02 UTC
isdnctrl $* >/dev/null 2>&1 && exit 1

is wrong, right is of course:

isdnctrl $* >/dev/null 2>&1 || exit 1


Comment 3 Ngo Than 2001-08-22 12:40:25 UTC
It's fixed in 6.25-1. You will find it in next rawhide release.



Note You need to log in before you can comment on or make changes to this bug.