Bug 522301 - setroubleshoot: SELinux is preventing abrtd "lock" access on /var/cache/abrt/kerneloops-1252547180-2.lock.
Summary: setroubleshoot: SELinux is preventing abrtd "lock" access on /var/cache/...
Keywords:
Status: CLOSED DUPLICATE of bug 522020
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:14ae67fe91f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 01:58 UTC by Sebastiano M. Cossu
Modified: 2009-09-10 19:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 07:58:58 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-10 01:58:24 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing abrtd "lock" access on
/var/cache/abrt/kerneloops-1252547180-2.lock.

Descrizione dettagliata:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       system_u:system_r:initrc_t:s0
Contesto target               system_u:object_r:abrt_var_cache_t:s0
Oggetti target                /var/cache/abrt/kerneloops-1252547180-2.lock [
                              file ]
Sorgente                      abrtd
Percorso della sorgente       /usr/sbin/abrtd
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        abrt-0.0.8.5-1.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-2.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat
                              Sep 5 21:01:10 EDT 2009 i686 i686
Conteggio avvisi              1
Primo visto                   gio 10 set 2009 03:46:20 CEST
Ultimo visto                  gio 10 set 2009 03:46:20 CEST
ID locale                     7724e78d-0728-48f6-b207-1718d09bcb06
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252547180.269:31): avc:  denied  { lock } for  pid=1288 comm="abrtd" path="/var/cache/abrt/kerneloops-1252547180-2.lock" dev=dm-0 ino=530679 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252547180.269:31): arch=40000003 syscall=221 success=yes exit=0 a0=7 a1=7 a2=bfd0ada0 a3=bfd0ada0 items=0 ppid=1 pid=1288 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:file lock;

Comment 1 Miroslav Grepl 2009-09-10 07:58:58 UTC

*** This bug has been marked as a duplicate of bug 522020 ***


Note You need to log in before you can comment on or make changes to this bug.