Bug 52232 - Machine non-bootable after install finishes - can't mount fs
Machine non-bootable after install finishes - can't mount fs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 16:28 EDT by Dan Hartman
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Hartman 2001-08-21 16:28:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808

Description of problem:
After a fresh install from the Roswell CD's, my machine can not mount
the / file system and continue to boot - I get an error complaining about
reading from hda.

When booting in rescue mode, the file system gets mounted correctly and all
appears to be fine.  I've tried using the partition tables I had before
(512mb swap / 4gig root), letting it repartition the whole drive, and each
combination with each bootloader and ext2 vs ext3.  All exhibitted the same
behavior.  Booting from a boot-floppy exhibits the exact same behavior

This appears to be somewhat related to my hardware, as the same install
worked fine on my laptop.

The failing hardware uses an Abit BH-6 MB (BX chipset) and a Western
Digital WDC AC35100L harddrive.  The system runs RH7.1 without any issues.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot from install CD's
2.Do any install on machine
3.Reboot to run newly installed OS
	

Additional info:
Comment 1 Glen Foster 2001-08-22 18:11:32 EDT
We (Red Hat) should really try to fix this before next release.
Comment 2 Arjan van de Ven 2001-08-22 18:18:34 EDT
Can you be a bit more specific about the complaint it gives ?
That might help me get an idea of where the problem can be.
Comment 3 Dan Hartman 2001-08-24 00:04:57 EDT
I can try, but it means reinstalling the machine twice - hopefully I'll have time to take it down over the weekend.
I'll try doing an upgrade first and see if I get the same problem, then a fresh install if the upgrade works.

I should have taken better notes the first time - wasn't thinking straight. DOH!
Comment 4 Dan Hartman 2001-08-26 21:15:18 EDT
Okay, I did another install (this time an upgrade) and got the same failure.  The bootscreen messages show:

...
Mounting root filesystem
hda1: bad access: block=2, count=2
end_request: I/O error, dev 03:01 (hda), sector 2
EXT3-fs: unable to read superblock
... (and things go down hill from there :)

Interestingly enough, I did a test install using the exact same system except a Quantum LCT15 drive, and
everything was great.  I remember seeing some info once suggesting some WD drives might have
problems with DMA modes, though my 7.1 install had DMA enabled.  Are the default DMA modes
different than before, and could that explain why the system mounts fine when booted from the install
or rescue disk, but poops out when running in 'normal' mode?

Does that give you guys/gals enough to go on?
Comment 5 Arjan van de Ven 2001-09-03 13:43:55 EDT
Could you try booting in rescue mode and install the 2.4.7 kernel from
http://people.redhat.com/arjanv/testkernels/i686/  ?
(you also need a mkinitrd in the "i386" directory one level up)
Comment 6 Dan Hartman 2001-09-05 10:41:46 EDT
I'll give that a try in the next day or so.  Unfortunately, this machine is my
main work machine, so I have to have it running a usable OS (7.1) during the day
hours. :)  I'll see if I have a spare drive to make this process a bit easier.
Comment 7 Dan Hartman 2001-09-09 15:36:26 EDT
I installed kernel 2.7.2-19 as requested and the system now boots fine.

Thanks!
Comment 8 Bugzilla owner 2004-09-30 11:39:07 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.