Bug 522378 - setroubleshoot: SELinux is preventing abrtd "setattr" access on kerneloops-1252532916-4.
Summary: setroubleshoot: SELinux is preventing abrtd "setattr" access on kerneloo...
Keywords:
Status: CLOSED DUPLICATE of bug 522020
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:9e141fdba91...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 09:08 UTC by Rodd Clarkson
Modified: 2009-09-10 11:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 11:27:05 UTC


Attachments (Terms of Use)

Description Rodd Clarkson 2009-09-10 09:08:06 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing abrtd "setattr" access on kerneloops-1252532916-4.

Detailed Description:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:abrt_var_cache_t:s0
Target Objects                kerneloops-1252532916-4 [ dir ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-0.0.8.5-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.30-4.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 #1 SMP Tue
                              Aug 11 21:00:45 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Thu 10 Sep 2009 07:48:36 EST
Last Seen                     Thu 10 Sep 2009 07:48:36 EST
Local ID                      43840f76-6861-4280-b641-9e7b5a56288e
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252532916.225:28): avc:  denied  { setattr } for  pid=1242 comm="abrtd" name="kerneloops-1252532916-4" dev=dm-5 ino=146611 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1252532916.225:28): arch=c000003e syscall=90 success=yes exit=0 a0=21a3c88 a1=1c0 a2=0 a3=7fffc5998e40 items=0 ppid=1 pid=1242 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:dir setattr;

Comment 1 Miroslav Grepl 2009-09-10 11:27:05 UTC

*** This bug has been marked as a duplicate of bug 522020 ***


Note You need to log in before you can comment on or make changes to this bug.