This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 52238 - Klock does not show some screensavers
Klock does not show some screensavers
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 16:47 EDT by Sammy
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-27 09:57:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sammy 2001-08-21 16:47:26 EDT
Description of Problem:

For the latest kdebase-2.2-4 rpms when one chooses Bouboule
or Rock (or few others) for a screensaver then tries to lock the
screen no screensaver will show. Only the password box with
a frozen background will show instead.

For Polygon, Lines etc. everything works fine. None of the GL
savers work either.

ALL savers work/test correctly in the kscreensaver windows!!

This has been reported to KDE bugs as well by few people but
I noticed that they also used RedHat packages. Not clear whether
a packaging issue or a KDE bug.

Version-Release number of selected component (if applicable):

kdebase-2.2-4

How Reproducible:

Always


Steps to Reproduce:
1. Select Bouboule from the kscreensaver menu
2. Try to lock the screen
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Glen Foster 2001-08-22 18:12:16 EDT
We (Red Hat) should really try to fix this before next release.
Comment 2 Bernhard Rosenkraenzer 2001-08-27 07:33:38 EDT
KLock actually does the right thing and calls e.g. kbouboule.kss --root.

Running kbouboule.kss --root from a konsole or xterm doesn't work either.
This is definitely not a packaging problem; looks like the screensaver can't 
grab the root window for some reason.

Might be an X problem; debugging.
Comment 3 Bernhard Rosenkraenzer 2001-08-27 07:57:57 EDT
After some more debugging, I believe it's an X problem:
XSetForeground() , XFillRectangle() etc. don't seem to have any effect even 
though they're called on the correct (root) window.

Comment 4 Bernhard Rosenkraenzer 2001-08-27 08:00:55 EDT
On another look, maybe it isn't after all - kdesktop seems to be showing on 
top of the screensaver (running the thing from a failsafe session (twm + 
xterm) works).

(Might still be an X problem though; I'm not sure how somewhat conflicting 
low-level X calls should be handled)
Comment 5 Bernhard Rosenkraenzer 2001-08-27 08:25:03 EDT
Submitted to KDE bug tracking system as 31663
Comment 6 Bernhard Rosenkraenzer 2001-08-27 09:57:43 EDT
Found it. The problem is that KDesktop is no longer drawing its background and 
icons on the root window itself - the screensavers are displayed under 
KDesktop.
The screensavers need to be displayed on KDesktop's window rather than the 
real root window.

Comment 7 Bernhard Rosenkraenzer 2001-08-29 10:38:35 EDT
Fixed in kdebase 2.2-9

Note You need to log in before you can comment on or make changes to this bug.