Bug 52246 - Guppi fails to install built libs
Guppi fails to install built libs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: libtool (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On: 58664
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 19:11 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-12 22:21:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-21 19:11:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.6-3.1 i686)

Description of problem:
Guppi bulds alright from source, but when installing some already built
libraries are not installed in the rpm-file.


Version-Release number of selected component (if applicable):
Guppi-0.35.5-7.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Rebuild from source and install
2.
3.
	

Additional info:

rpm -Uvh /usr/src/redhat/RPMS/i686
...
error: failed dependencies:
	libguppibonobo.so.11   is needed by Guppi-0.35.5-7
	libguppidata.so.11   is needed by Guppi-0.35.5-7
	libguppidataui.so.11   is needed by Guppi-0.35.5-7
	libguppieval.so.11   is needed by Guppi-0.35.5-7
	libguppimath.so.11   is needed by Guppi-0.35.5-7
	libguppiplot.so.11   is needed by Guppi-0.35.5-7
	libguppispecfns.so.11   is needed by Guppi-0.35.5-7
	libguppistat.so.11   is needed by Guppi-0.35.5-7

These libraries are built in /usr/src/redhat/BUILD but not installed to
/var/tmp!

Guppi-0.35.5.7
rpm-4.0.3-0.88
Comment 1 Need Real Name 2001-09-17 17:35:51 EDT
Guppi fails to build correctly: (parts of build log)
make[3]: Entering directory `/usr/src/redhat/BUILD/Guppi-0.35.5/src/libguppibonobo'
/bin/sh ../../mkinstalldirs /var/tmp/Guppi-0.35.5-root/usr/lib
/bin/sh ../../libtool  --mode=install /usr/bin/install -c libguppibonobo.la
/var/tmp/Guppi-0.35.5-root/usr/lib/libguppibonobo.la
libtool: install: warning: relinking `libguppibonobo.la'
cd /usr/src/redhat/BUILD/Guppi-0.35.5/src/libguppibonobo; /bin/sh ../../libtool
--mode=relink gcc -O2 -march=i386 -mcpu=i686 -Wall -Wunused -o libguppibonobo.la
-rpath /usr/lib -version-info 11:0:0 -lbonobo-print -rdynamic -L/usr/lib
-L/usr/X11R6/lib -lbonobo -loaf -lORBitCosNaming -lORBit -lIIOP -lORBitutil
-lnsl -lbonobox -lbonobo-print -lgnomeprint -lgnomeui -lart_lgpl -lgdk_imlib
-lSM -lICE -lgnome -lgnomesupport -lesd -laudiofile -ldb1 -lgdk_pixbuf -lgtk
-lgdk -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm -lxml -lz guppi-bonobo.lo
guppi-embeddable.lo guppi-bonobo-canned-demo.lo guppi-bonobo-print.lo
guppi-bonobo-view.lo ../libguppiuseful/libguppiuseful.la
../libguppiplot/libguppiplot.la ../libguppidata/libguppidata.la
gcc -shared  guppi-bonobo.lo guppi-embeddable.lo guppi-bonobo-canned-demo.lo
guppi-bonobo-print.lo guppi-bonobo-view.lo 
-L/usr/src/redhat/BUILD/Guppi-0.35.5/src/libguppiuseful/.libs
-L/usr/src/redhat/BUILD/Guppi-0.35.5/src/libguppidata/.libs
-L/usr/lib/python1.5/config -lbonobo-print -L/usr/lib -L/usr/X11R6/lib -lbonobo
-loaf -lORBitCosNaming -lORBit -lIIOP -lORBitutil -lnsl -lbonobox -lbonobo-print
-lgnomeprint -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgnome -lgnomesupport
-lesd -laudiofile -ldb1 -lgdk_pixbuf -lgtk -lgdk -lgmodule -lglib -ldl -lXi
-lXext -lX11 -lm -lxml -lz -lguppiuseful -lguppiplot -lguppidata     -Wl,-soname
-Wl,libguppibonobo.so.11 -o .libs/libguppibonobo.so.11.0.0
/usr/bin/ld: cannot find -lguppiplot
collect2: ld returned 1 exit status
libtool: install: error: relink `libguppibonobo.la' with the above command
before installing it
libtool: install: warning: remember to run `libtool --finish /usr/lib'

Cause of problems: The libraries are named with extension U and therefore not
found resulting in broken links, such as 
libguppidata.so,  libguppidata.so.11 -> libguppidata.so.11.0.0
(don't know why, nothing found in the makefiles)

libguppibonobo.so.11.0.0U
libguppispecfns.so.11.0.0U
libguppidata.so.11.0.0U
libguppidataui.so.11.0.0U
libguppimath.so.11.0.0U
libguppistat.so.11.0.0U
libguppieval.so.11.0.0U
libguppiplot.so.11.0.0U
libguppitank.so.11.0.0U

The reason the package builds is that build dependencies are on .so.11 links,
not on the real libraries.
Comment 2 Bill Nottingham 2002-01-24 01:25:58 EST
libtool damage, it appears.
Comment 3 Bill Nottingham 2002-02-05 22:25:12 EST
This will be fixed when libtool stops trying to relink things, I believe.
Comment 4 Jens Petersen 2002-05-21 04:54:18 EDT
On a 7.3-ish install when I try to rebuild Guppi-0.35.5-7 with
libtool-1.4.2-[78] I get

/bin/sh ../../libtool --mode=link gcc  -O2 -march=i386 -mcpu=i686 -Wall -Wunused
  -o libguppispecfns.la -rpath /usr/lib -version-info 11:0:0  -lm -lglib bdtr.lo
btdtr.lo chdtr.lo choose.lo const.lo fdtr.lo gamma.lo gdtr.lo hypergeom.lo
igam.lo igami.lo incbet.lo incbi.lo mtherr.lo nbdtr.lo ndtr.lo ndtri.lo pdtr.lo
polyeval.lo stdtr.lo unity.lo ../libguppiuseful/libguppiuseful.la 
libtool: link: error: cannot link shared libraries into libtool libraries

Anyway Guppi-0.40.3-5 seems to build without any problems, so
I think I will close this for now.

Note You need to log in before you can comment on or make changes to this bug.