Bug 522476 - classpathx-jaf wrong alternatives code cause conflicts with glassfish-jaf among others
Summary: classpathx-jaf wrong alternatives code cause conflicts with glassfish-jaf amo...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: classpathx-jaf
Version: 5.7
Hardware: All
OS: Linux
urgent
medium
Target Milestone: ---
: 5.9
Assignee: David Walluck
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 12:49 UTC by Joe Orton
Modified: 2014-09-01 13:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:21:54 UTC


Attachments (Terms of Use)

Description Joe Orton 2009-09-10 12:49:57 UTC
Description of problem:
This problem was seen in QA testing of the Application Stack; an install of EAP 4.2 pulls in classpathx-jaf.  An install of EAP 4.3 pulls in glassfish-jaf.  The two packages conflict, so upgrading from 4.2 to 4.3 doesn't work.

Version-Release number of selected component (if applicable):
classpathx-jaf-1.0-9jpp.1
glassfish-jaf-1.1.0-0jpp.ep1.12.el5.1

How reproducible:
always

Steps to Reproduce:
1. clean install RHEL5
2. subscribe to EAP 4.2 channel
3. # yum install classpathx-jaf
4. subscribe to EAP 4.3 channel in place of 4.3 channel
5. # yum install glassfish-jaf

Actual results:
Transaction Check Error:
  file /usr/share/java/activation.jar from install of glassfish-jaf-1.1.0-0jpp.ep1.12.el5.1.noarch conflicts with file from package classpathx-jaf-1.0-9jpp.1.i386

Expected results:
upgrade succeeds

Additional info:

Comment 1 Permaine Cheung 2009-09-10 15:45:18 UTC
I checked the latest jbossas rpm for both EAP 4.2 and 4.3, on RHEL 5, we don't have that Requires: on neither classpathx-jaf nor glassfish-jaf in there. It's probably pulled in as an indirect dependency.
What commands do you use for installation, "yum install jbossas"?

Comment 2 Joe Orton 2009-09-10 16:12:47 UTC
Yes, "yum install jbossas".  The dependency change is:

--> Processing Dependency: jbossws >= 2.0.1-3.SP2_CP06 for package: jbossas
--> Processing Dependency: glassfish-jaf for package: jbossws

Comment 3 Permaine Cheung 2009-09-10 16:31:20 UTC
I think we need to fix the jbossws package to include the jar instead of requiring the glassfish-jaf package, similar to what we do in the jbossas package on RHEL-5.

Comment 4 Fernando Nasser 2010-08-31 23:39:01 UTC
It is actually a wrong code in classpathx-jaf creating of the activation.jar alternatives link that causes all these problems.

It is now became urgent that we fix classpathx-jaf as it is interfering with the installation of the EAP 5.1.0 on RHEL-5.  That requires the installation of the glassfish-jaf package, which fails due to this conflict, so we have to ask the customer to remove tomcat5 and eclipse.

Our tomcat5 5.5.23 including the one in RHEL is being tested against the javamail JAR in glassfish-javamail, so installing that package with the product and switching altermatives works and has been QAed as part of the EWS 1.0.1 product.

Comment 5 RHEL Product and Program Management 2012-06-12 01:30:20 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 6 RHEL Product and Program Management 2014-03-07 13:53:16 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 7 RHEL Product and Program Management 2014-06-02 13:21:54 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.