Bug 522497 - Root password mandatory when modifying System Details in kickstart editor
Summary: Root password mandatory when modifying System Details in kickstart editor
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: 530
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Partha Aji
QA Contact: Dimitar Yordanov
URL:
Whiteboard:
Depends On:
Blocks: sat540-blockers
TreeView+ depends on / blocked
 
Reported: 2009-09-10 14:36 UTC by Jérôme Fenal
Modified: 2010-10-28 14:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-28 14:47:33 UTC


Attachments (Terms of Use)

Description Jérôme Fenal 2009-09-10 14:36:43 UTC
Description of problem:

At :
https://<sat url>/rhn/kickstart/SystemDetailsEdit.do

When modifying system details in a kickstart, such as SELinux or RHN Configuration management, root password modification is now mandatory, and one cannot leave the two fields empty.

Version-Release number of selected component (if applicable):

5.3

How reproducible:

Always

Steps to Reproduce:
1. Create a kickstart, or use an already defined one
2. Go to its System Details
3. Click a check box/radio button, leaving password field empty, commit.
  
Actual results:

Error :     * A root password must be entered

Expected results:

No error, root password not modified if fields are left empty, as it used to be pre-5.3


Additional info:

Comment 3 Jérôme Fenal 2010-09-10 13:40:31 UTC
Hi,

just reproduced it on a Satellite not updated since last Feb. with the following "rpm -qa | grep spacewalk" :

spacewalk-backend-config-files-0.5.28-34.el5sat
spacewalk-monitoring-0.5.4-4.el5sat
spacewalk-admin-0.5.15-1.el5sat
spacewalk-backend-tools-0.5.28-34.el5sat
spacewalk-selinux-0.5.4-10.el5sat
spacewalk-base-minimal-0.5.23-29.el5sat
spacewalk-pxt-0.5.23-29.el5sat
spacewalk-backend-sql-0.5.28-34.el5sat
spacewalk-backend-xmlrpc-0.5.28-34.el5sat
spacewalk-backend-iss-export-0.5.28-34.el5sat
spacewalk-backend-upload-server-0.5.28-34.el5sat
spacewalk-ssl-cert-check-1.7-1.el5sat
spacewalk-search-0.5.10-15.el5sat
spacewalk-schema-0.5.20-23.el5sat
spacewalk-java-lib-0.5.44-50.el5sat
spacewalk-taskomatic-0.5.44-50.el5sat
spacewalk-grail-0.5.23-29.el5sat
spacewalk-certs-tools-0.5.5-6.el5sat
spacewalk-backend-0.5.28-34.el5sat
spacewalk-backend-xml-export-libs-0.5.28-34.el5sat
spacewalk-backend-xp-0.5.28-34.el5sat
spacewalk-backend-iss-0.5.28-34.el5sat
spacewalk-utils-0.5.1-8.el5sat
spacewalk-monitoring-selinux-0.5.7-10.el5sat
spacewalk-java-config-0.5.44-50.el5sat
spacewalk-html-0.5.23-29.el5sat
spacewalk-moon-0.5.23-29.el5sat
spacewalk-config-0.5.9-15.el5sat
spacewalk-backend-config-files-common-0.5.28-34.el5sat
spacewalk-backend-app-0.5.28-34.el5sat
spacewalk-backend-config-files-tool-0.5.28-34.el5sat
spacewalk-backend-applet-0.5.28-34.el5sat
spacewalk-dobby-0.5.23-28.el5sat
spacewalk-base-0.5.23-29.el5sat
spacewalk-sniglets-0.5.23-29.el5sat
spacewalk-koan-0.1.11-13.el5sat
spacewalk-backend-server-0.5.28-34.el5sat


Got the "A root password must be entered" message, in red.
HTML associated code : 

<div class="local-alert"><ul><li>A root password must be entered</li></ul><br /></div>

Comment 4 Miroslav Suchý 2010-10-20 10:28:45 UTC
I got no error and password before editing System Details is
rootpw --iscrypted $1$FJoHchHr$f5vGbNo1M8L3wTxY.YpZH.
after editing, with leaving password field empty it is still
rootpw --iscrypted $1$FJoHchHr$f5vGbNo1M8L3wTxY.YpZH.

verified in stage

Comment 5 Clifford Perry 2010-10-28 14:42:55 UTC
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford


Note You need to log in before you can comment on or make changes to this bug.