Bug 52254 - Latex/dvi shifts page down by 1/2 inch vs. RedHat 7.1
Latex/dvi shifts page down by 1/2 inch vs. RedHat 7.1
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: tetex (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 21:45 EDT by Dave Reed
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-25 12:06:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/alchemist/namespace/printconf/local.adl (429 bytes, application/octet-stream)
2001-08-22 07:12 EDT, Dave Reed
no flags Details
syllabus.sty (6.03 KB, text/plain)
2001-08-22 07:13 EDT, Dave Reed
no flags Details
syllabus.tex (9.69 KB, text/plain)
2001-08-22 07:14 EDT, Dave Reed
no flags Details

  None (edit)
Description Dave Reed 2001-08-21 21:45:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
When running latex on relatively simple latex files, the resulting (Roswell
2) PostScript file resulting from running dvips -Ppdf on 
the file is shifted down on the page about half an inch vs. RedHat 7.1. I
also tried GhostScript 7.0 from the GhostScript site and the
problem still occurs. I will provide the latex file I have if it you
think it might be unique to my file or do not want to bother with
your own latex file. email: dreed@capital.edu

On both the 7.1 and roswell, I have changed the file:
/usr/share/texmf/xdvi/XDvi
so that the one line reads:
XDvi*paper: us

The problem could be with ghostscript, but the dvi files
differ on the two systems so I'm not certain.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. latex file.tex
2. dvips -Ppdf file -o
3. view the PostScript file and compare it to the same one on RedHat 7.1
	

Additional info:
Comment 1 Tim Waugh 2001-08-22 04:00:46 EDT
Yes, please attach a small file, so that we know we're looking at the same 
thing.

Could you also attach the output of 'zcat 
/etc/alchemist/namespace/printconf/local.adl'?

Thanks.
Comment 2 Dave Reed 2001-08-22 07:12:31 EDT
Created attachment 28874 [details]
/etc/alchemist/namespace/printconf/local.adl
Comment 3 Dave Reed 2001-08-22 07:13:35 EDT
Created attachment 28875 [details]
syllabus.sty
Comment 4 Dave Reed 2001-08-22 07:14:36 EDT
Created attachment 28876 [details]
syllabus.tex
Comment 5 Glen Foster 2001-08-22 18:12:21 EDT
We (Red Hat) should really try to fix this before next release.
Comment 6 Tim Waugh 2001-08-23 08:10:04 EDT
I think the change is introduced by the time the DVI is created.

On a 7.1 system, a Roswell-produced DVI is converted to PS containing
%%BoundingBox: 0 0 612 792

On a Roswell system, a 7.1-produced DVI is converted to PS containing
%%BoundingBox: 0 0 596 842
This is the same as doing the whole lot on a 7.1 system.

The main change between 7.1 and Roswell in the tetex package is to use a newer 
set of LaTeX macros.  Perhaps that's where the change has come from.

Interestingly enough, when these PS files are loaded into Ghostscript 
(Roswell), the Roswell-produced PS file is shown as 'Letter', while the 
7.1-produced PS file is shown as 'BBox'.

Also, gimp (again, on Roswell) shows the Roswell-produced PS to be 11"x8.5", 
while the 7.1-produced PS is 8.28"x11.7".

Could it be that the change is in fact a feature rather than a bug? ;-)
Comment 7 Dave Reed 2001-08-23 08:24:53 EDT
It could be a "new feature"; if so, could you please let me know what changes
were made to the Latex macros (or where you got them). We just installed
Latex on a Sparc Solaris system at work about a week ago and it works the same
as RedHat 7.1. This is going to be really annoying if I have to edit the file
everytime I try to print at work vs. home :-(
Comment 8 Tim Waugh 2001-08-23 08:30:22 EDT
The updated LaTeX macros came from the Mandrake package (from Guiseppe Ghibr's 
texmf-gg archive).

Comment 9 Dave Reed 2001-08-23 12:30:00 EDT
Ok, I am willing to admit that the RedHat 7.1 Latex and Solaris Latex are
wrong. Page 85 of the "Latex Companion" by Goossens et al. shows the
page layout and what the margins, etc. set with \setmarginsrb mean. Even
though I requested a top margin of 1 inch, the printout from 7.1 and Solaris
have a margin of less than inch. I'll check the roswell page printout tonight
to see if it appears correct. Looks like I'll have to get Latex compiled for
Solaris from the texmf-gg source archive :-(
Comment 10 Tim Waugh 2001-08-23 17:33:46 EDT
Okay, I spoke to Guiseppe about this, and he thinks that it's probably a paper 
size bug in the dvips configuration.  I'll take a closer look at it, and try 
things like 'dvips -t a4' to see if that makes things better.
Comment 11 Dave Reed 2001-08-23 20:33:32 EDT
After measuring the output of the roswell PostScript file and looking at the
Latex Companion, I think the 7.1 output (and the binary Solaris files that
were installed at work) are wrong and that roswell is correct. I'd really
like to know how to make 7.1 produce the same output as roswell so I can
try the same thing on the Solaris machine.
Comment 12 Dave Reed 2001-08-25 12:06:17 EDT
I tried switching from the Latex macro:
\setmarginsrb{1.0in}{0.5in}{1.0in}{0.25in}%
{12pt}{0.25in}{12pt}{0.5in}

to:
\setmargins{1.0in}{0.5in}{6.5in}{9.0in}
{12pt}{0.25in}{12pt}{0.5in}

and using: dvips -t letter

Then both the RedHat 7.1 system and the Roswell system produce PostScript that
look the same. Unfortunately, trying to print the PostScript file from the 7.1
system hangs the printer. Printing the PostScript file generated on the 7.1
system (or the roswell system) from the roswell system to the HP LaserJet 1100
(connected to the 7.1 system) works fine. This appears to be the 7.1 bug that
has not been fixed yet:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=42663

I believe a member of our local Linux User Group (colug) who has contacts at
RedHat talked to someone and they tracked it down to manually processing
the PostScript file for printing vs. letting the filter do it (it worked
when manually processing the filters).

Which roswell src.rpm would I try to rebuild on the 7.1 system? I'm guessing:
LPRng
Comment 13 Tim Waugh 2001-09-11 06:51:05 EDT
I guess, from the sound of it.

Marking this bug closed.
Comment 14 Dave Reed 2001-09-11 07:32:23 EDT
Actually, it's not LPRng (since I recompiled the src RPM on my 7.1 system.
It's somewhere in the printconf RPMS and it's dependencies. There were too
many RPMS that needed updated to install the roswell printconf on a 7.1 system.

Yes, I agree that this bug should be closed for roswell. The 7.1 bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=42663

still exists, although upgrading to RedHat 7.2 whenever it comes out
will solve it.

Note You need to log in before you can comment on or make changes to this bug.