Bug 52255 - rawhide pine does not work with sendmail
rawhide pine does not work with sendmail
Status: CLOSED DUPLICATE of bug 52226
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 21:52 EDT by Stephen John Smoogen
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-21 21:52:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2001-08-21 21:52:42 EDT
Description of Problem:

In trying to test if certain patches had made it in, I upgraded this
evening to various RPMs out of this mornings rawhide. After doing so, pine
no longer would send email. It would begin to do so say [Sending mail 0%]
and then stop.. looking at gdb it was just sitting waiting for sendmail to
do something. Looking at the changelog I am guessing that this is the cause
of it:

* Thu Aug 16 2001 Mike A. Harris <mharris@redhat.com> 4.33-14

- Created sendmail-options patch to remove "-bs", and add "-t -oi"
  to sendmail invocation options.  This gets rid of sendmail complaints
  in maillog of "process foo invoked sendmail with -bs".

Looked in maillog and messages and dont see any errors. I have worked
around the problem by either changing the .pinerc to use the local smtp MX
box.. or to put the line 

sendmail-path=/usr/lib/sendmail -oem -t -oi

which causes sendmail to not hang but also not queue :)

I set up a dummy user to see if it was my .pinerc, but I was able to
replicate it there.

Version-Release number of selected component (if applicable):

pine-4.33-14
Comment 1 Mike A. Harris 2001-08-21 22:19:51 EDT
Filed by Trond, fixed not long after in -15.  I guess you must have
missed that one when you queried bugzilla for already reported and/or
resolved bugs tho...  ;o)  Could happen to anyone...  ;o)

<grin>

*** This bug has been marked as a duplicate of 52226 ***

Note You need to log in before you can comment on or make changes to this bug.