Bug 522550 - Unable to Fast User Switching on Radeon Video Driver
Unable to Fast User Switching on Radeon Video Driver
Status: CLOSED DUPLICATE of bug 512944
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-10 13:00 EDT by CAI Qian
Modified: 2009-10-21 13:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 13:41:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Smolt Profile (7.13 KB, text/plain)
2009-09-10 13:00 EDT, CAI Qian
no flags Details
dmesg (34.15 KB, text/plain)
2009-09-10 13:01 EDT, CAI Qian
no flags Details
Xorg.0.log (55.24 KB, text/plain)
2009-09-10 13:28 EDT, CAI Qian
no flags Details

  None (edit)
Description CAI Qian 2009-09-10 13:00:16 EDT
Created attachment 360535 [details]
Smolt Profile

Description of problem:
When doing fast user switching, it pops up a window and the screen goes black until moving a mouse or clicking a key, which gives the initial login window and there is no second user account available to select.

  Unable to start new display

  The name org.gnome.DisplayManager was not provided by any .service files

Version-Release number of selected component (if applicable):
gdm-2.27.90-2.fc12.x86_64
gdm-user-switch-applet-2.27.90-2.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1. Ensure the 'nomodeset' in your bootloader configuration (need it for basic
   X operation to suceed).
2. Ensure the file /etc/X11/xorg.conf does not exist, or is a known-good
   configuration file that uses the 'radeon' driver
3. Shut your system down entirely, then start it up again
4. Create a second regular user account, if you do not already have one
   available
5. Trigger fast switching (in a default Fedora desktop, click your name at
   the top right hand corner, then select Switch User) 
  
Actual results:
Error window pops up.

Expected results:
Fast user switching should work correctly, with no display issues on either desktop.
Comment 1 CAI Qian 2009-09-10 13:01:05 EDT
Created attachment 360536 [details]
dmesg
Comment 2 CAI Qian 2009-09-10 13:28:34 EDT
Created attachment 360537 [details]
Xorg.0.log
Comment 3 Dave Airlie 2009-10-07 04:56:24 EDT
I don't think this is a driver issue, please retry with latest -ati/X server packages from rawhide.

Its more likely a gdm bug.
Comment 4 CAI Qian 2009-10-07 07:11:58 EDT
The testing is blocked due to the bug 522129.
Comment 5 Adam Williamson 2009-10-21 13:41:21 EDT
we've been investigating this in the blocker bug review meeting this morning. it seems there are many reports of this type across multiple types of video hardware. closing all reports as dupes of 512944, which is the earliest report. 512944 will be marked as a release blocker.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 512944 ***

Note You need to log in before you can comment on or make changes to this bug.