Bug 522590 - setroubleshoot: SELinux is preventing abrtd "remove_name" access on kerneloops-1252323162-1.lock.
Summary: setroubleshoot: SELinux is preventing abrtd "remove_name" access on kern...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:1f95c73119e...
: 522596 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 18:53 UTC by Kjartan Maraas
Modified: 2009-09-10 19:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 19:40:42 UTC


Attachments (Terms of Use)

Description Kjartan Maraas 2009-09-10 18:53:02 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing abrtd "remove_name" access on
kerneloops-1252323162-1.lock.

Detailed Description:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:abrt_var_cache_t:s0
Target Objects                kerneloops-1252323162-1.lock [ dir ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-0.0.8.5-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.30-4.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.204.rc9.fc12.i686.PAE #1 SMP Sat Sep 5
                              20:45:47 EDT 2009 i686 i686
Alert Count                   2
First Seen                    to. 10. sep. 2009 kl. 21.29 +0000
Last Seen                     to. 10. sep. 2009 kl. 21.29 +0000
Local ID                      92e7de99-8941-4e2f-8f46-0a170e018fa6
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252610990.714:13): avc:  denied  { remove_name } for  pid=1236 comm="abrtd" name="kerneloops-1252323162-1.lock" dev=dm-0 ino=277152 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252610990.714:13): avc:  denied  { unlink } for  pid=1236 comm="abrtd" name="kerneloops-1252323162-1.lock" dev=dm-0 ino=277152 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252610990.714:13): arch=40000003 syscall=10 success=yes exit=0 a0=9874084 a1=1 a2=7e6ff4 a3=9874084 items=0 ppid=1 pid=1236 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:dir remove_name;
allow initrc_t abrt_var_cache_t:file unlink;

Comment 1 Daniel Walsh 2009-09-10 19:40:42 UTC
Fixed in selinux-policy-3.6.30-5.fc12.noarch

Comment 2 Daniel Walsh 2009-09-10 19:41:58 UTC
*** Bug 522596 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.