Bug 52260 - KWin barfs if you have two desktop clients
Summary: KWin barfs if you have two desktop clients
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-22 03:26 UTC by Havoc Pennington
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-26 23:06:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Havoc Pennington 2001-08-22 03:26:29 UTC
If you have two clients that set the _NET_WM_WINDOW_TYPE to
_NET_WM_WINDOW_TYPE_DESKTOP, then KWin does really bizarre things and gets
confused, specifically it puts a giant gray window on top of your screen.
If you look at the code in workspace.cpp it looks like the code does not
anticipate this situation.

Bug discovered with a version of Nautilus I haven't put in the tree yet
that sets _NET_WM_WINDOW_TYPE. I'll try to build it soon. Running kdesktop
twice may also trigger it, I don't know.

(BTW, if I get Nautilus running under KDE, then try to run kdesktop,
kdesktop  just dies with some error about nonexistent signals/slots or
something. So I haven't tested what happens if Nautilus is the first
desktop window and kdesktop the second.)

I made Nautilus set the desktop hint to try to avoid problems if users
choose it from the menu, since without the hint Nautilus covers up your
whole KDE desktop. My thought was that at least Nautilus would be below the
KDE panel. This would help fix a should-fix bug about launching Nautilus in
KDE.

Comment 1 Glen Foster 2001-08-22 22:11:46 UTC
We (Red Hat) should really try to fix this before next release.

Comment 2 Ngo Than 2004-09-26 23:06:19 UTC
it seems it's fixed in rawhide with KDE 3.3.0 and nautilus-2.8.0


Note You need to log in before you can comment on or make changes to this bug.