Bug 522608 - setroubleshoot: SELinux is preventing abrtd "remove_name" access on kerneloops-1252585239-2.lock.
Summary: setroubleshoot: SELinux is preventing abrtd "remove_name" access on kern...
Keywords:
Status: CLOSED DUPLICATE of bug 522606
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:cd870a1fb9a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 20:00 UTC by Sebastiano M. Cossu
Modified: 2009-10-20 20:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-20 20:59:00 UTC


Attachments (Terms of Use)

Description Sebastiano M. Cossu 2009-09-10 20:00:23 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing abrtd "remove_name" access on
kerneloops-1252585239-2.lock.

Descrizione dettagliata:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       system_u:system_r:initrc_t:s0
Contesto target               system_u:object_r:abrt_var_cache_t:s0
Oggetti target                kerneloops-1252585239-2.lock [ dir ]
Sorgente                      abrtd
Percorso della sorgente       /usr/sbin/abrtd
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        abrt-0.0.8.5-1.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-4.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat
                              Sep 5 21:01:10 EDT 2009 i686 i686
Conteggio avvisi              2
Primo visto                   gio 10 set 2009 14:20:39 CEST
Ultimo visto                  gio 10 set 2009 14:20:39 CEST
ID locale                     1e185a0d-b3ca-42ab-988b-97b4ad203fac
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252585239.300:38): avc:  denied  { remove_name } for  pid=1249 comm="abrtd" name="kerneloops-1252585239-2.lock" dev=dm-0 ino=528401 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252585239.300:38): avc:  denied  { unlink } for  pid=1249 comm="abrtd" name="kerneloops-1252585239-2.lock" dev=dm-0 ino=528401 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252585239.300:38): arch=40000003 syscall=10 success=yes exit=0 a0=95a2a3c a1=1 a2=ca8ff4 a3=95a2a3c items=0 ppid=1 pid=1249 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:dir remove_name;
allow initrc_t abrt_var_cache_t:file unlink;

Comment 1 Daniel Walsh 2009-10-20 20:59:00 UTC

*** This bug has been marked as a duplicate of bug 522606 ***


Note You need to log in before you can comment on or make changes to this bug.