Bug 522609 - AttributeError: 'NoneType' object has no attribute 'startswith'
AttributeError: 'NoneType' object has no attribute 'startswith'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
anaconda_trace_hash:c48177fb010f7dae6...
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-09-10 16:00 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 03:42:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (334.84 KB, text/plain)
2009-09-10 16:00 EDT, Jay Turner
no flags Details
Attached traceback automatically from anaconda. (135.28 KB, text/plain)
2009-10-06 01:15 EDT, Jesse Keating
no flags Details
Attached traceback automatically from anaconda. (134.33 KB, text/plain)
2009-10-07 15:05 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (152.05 KB, text/plain)
2009-10-08 07:20 EDT, Martin Banas
no flags Details

  None (edit)
Description Jay Turner 2009-09-10 16:00:48 EDT
The following was filed automatically by anaconda:
anaconda 12.21 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/__init__.py", line 686, in formatByDefault
    if device.format.mountpoint.startswith(p):
  File "/usr/lib/anaconda/iw/raid_dialog_gui.py", line 275, in run
    self.storage.formatByDefault(self.origrequest):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1093, in editRaidArray
    actions = raideditor.run()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1076, in editCB
    self.editRaidArray(device)
AttributeError: 'NoneType' object has no attribute 'startswith'
Comment 1 Jay Turner 2009-09-10 16:00:52 EDT
Created attachment 360563 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-09-10 16:03:25 EDT
This bug was discovered while attempting to add several fedora partitions while leaving several existing RAID1 devices untouched.
Comment 3 James Laska 2009-09-10 16:09:23 EDT
Adding to F12Blocker list for consideration.  This defect seems to be related to having existing RAID members and devices that are left untouched during an install operation.
Comment 4 James Laska 2009-09-10 16:20:03 EDT
Changing to version=rawhide
Comment 5 Jesse Keating 2009-10-06 01:15:49 EDT
Created attachment 363776 [details]
Attached traceback automatically from anaconda.
Comment 6 Hans de Goede 2009-10-06 08:41:52 EDT
This should be fixed by this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=ba96feb99d25b55c4b52abbb1c8e3b06ee17ccbc

Which will be in anaconda-12.34-1

Changing bug to MODIFIED
Comment 7 James Laska 2009-10-07 15:05:06 EDT
Created attachment 364021 [details]
Attached traceback automatically from anaconda.
Comment 8 James Laska 2009-10-07 15:07:00 EDT
Reproduced (see comment#7) using anaconda-12.34 (which doesn't yet have the fix). The reproducer for me was 'custom partitioning', then trying to format an existing /dev/md0 RAID device.
Comment 9 James Laska 2009-10-07 15:46:30 EDT
typo ... comment#8 should have read ...

(In reply to comment #8)
                                              VVVV
> Reproduced (see comment#7) using anaconda-12.33 (which doesn't yet have the
                                              ^^^^
> fix). The reproducer for me was 'custom partitioning', then trying to format an
> existing /dev/md0 RAID device.
Comment 10 Martin Banas 2009-10-08 07:20:39 EDT
Created attachment 364086 [details]
Attached traceback automatically from anaconda.
Comment 11 Hans de Goede 2009-10-21 03:42:26 EDT
rawhide has been using a newer anaconda with the fix in for a while now, closing.

Note You need to log in before you can comment on or make changes to this bug.