Bug 522621 - BuildRequires: cairo-devel needs to be versioned (higher)
Summary: BuildRequires: cairo-devel needs to be versioned (higher)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: poppler
Version: rawhide
Hardware: All
OS: All
low
low
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 20:38 UTC by Moritz Barsnick
Modified: 2009-09-11 18:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-11 18:06:17 UTC


Attachments (Terms of Use)

Description Moritz Barsnick 2009-09-10 20:38:28 UTC
Description of problem:
poppler SRPM can't be rebuilt on F10 due to cairo-devel version mismatch, but BuildRequires fails to catch this.

Version-Release number of selected component (if applicable):
poppler-0.11.3-1

How reproducible:
on F10 (or any distro/version with cairo-devel < 1.8.4)

Steps to Reproduce:
1. rpmbuild --rebuild poppler-0.11.3-1.fc12.src.rpm
  
Actual results:
./configure fails due to cairo-devel 1.8.0 instead of >= 1.8.4 available.

Expected results:
rpm notices that cairo-devel >= 1.8.4 is required to build this package.

Additional info:
While I guess poppler-0.11/0.12 may not be planned for F10, this issue is still easily caught. I realize that policy is (officially?) that Requires/BuildRequires need not be versioned if the supported distributions fulfil that version anyway. Not sure whether F10 counts, or doesn't if this version isn't planned.

I also don't understand why F10 doesn't have a newer cairo. *shrug*

So I suggest this change to poppler.spec:
-BuildRequires: cairo-devel
+BuildRequires: cairo-devel >= 1.8.4
+Requires: cairo >= 1.8.4

Oh, and please bump Rawhide to 0.12.0. :)

Comment 1 Moritz Barsnick 2009-09-10 20:39:32 UTC
(Changed Summary, I had pressed return too early.)

Comment 2 Rex Dieter 2009-09-11 18:06:17 UTC
I'll add the BuildRequires at least, the explicit Requires, no.

cvs only, no rebuild for this.

p.s. poppler-0.12.0 was built for rawhide on 9/9


Note You need to log in before you can comment on or make changes to this bug.