Description of problem:
poppler SRPM can't be rebuilt on F10 due to cairo-devel version mismatch, but BuildRequires fails to catch this.
Version-Release number of selected component (if applicable):
on F10 (or any distro/version with cairo-devel < 1.8.4)
Steps to Reproduce:
1. rpmbuild --rebuild poppler-0.11.3-1.fc12.src.rpm
./configure fails due to cairo-devel 1.8.0 instead of >= 1.8.4 available.
rpm notices that cairo-devel >= 1.8.4 is required to build this package.
While I guess poppler-0.11/0.12 may not be planned for F10, this issue is still easily caught. I realize that policy is (officially?) that Requires/BuildRequires need not be versioned if the supported distributions fulfil that version anyway. Not sure whether F10 counts, or doesn't if this version isn't planned.
I also don't understand why F10 doesn't have a newer cairo. *shrug*
So I suggest this change to poppler.spec:
+BuildRequires: cairo-devel >= 1.8.4
+Requires: cairo >= 1.8.4
Oh, and please bump Rawhide to 0.12.0. :)
(Changed Summary, I had pressed return too early.)
I'll add the BuildRequires at least, the explicit Requires, no.
cvs only, no rebuild for this.
p.s. poppler-0.12.0 was built for rawhide on 9/9