Bug 52264 - will not mount 100MB disk in 250MB drive
will not mount 100MB disk in 250MB drive
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: kudzu (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-22 01:36 EDT by Brian Gunney
Modified: 2014-03-16 22:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-23 00:31:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Gunney 2001-08-22 01:36:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.6-3.1 i686)

Description of problem:
The kudzu line for an Iomega 250MB Zip drive uses /dev/hdc4 for that
device. It works for 250MB disks but not for 100MB disks. 100MB disks are
mountable on /dev/hdc instead, but that is not what kudzu gives. (Maybe
this is not really a kudzu bug.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.You should get this line in fstab:
/dev/hdc4 /mnt/zip250.0 auto noauto,owner,kudzu 0 0
2.put 100MB in 250MB Zip drive
3.mount /mnt/zip250.0

Actual Results:  > mount /mnt/zip250.0
/dev/hdc4: No such file or directory
mount: you must specify the filesystem type
> mount /dev/hdc4 /mnt/zip250.0
/dev/hdc4: Success
mount: you must specify the filesystem type
> mount -t ext2 /dev/hdc4 /mnt/zip250.0
mount: wrong fs type, bad option, bad superblock on /dev/hdc4,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

Using /dev/hdc instead of /dev/hdc4 works:
> mount /dev/hdc /mnt/zip250.0

(Mounting a 250MB in the same drive works without problem.)

Additional info:

This occured on a Dell Latitude laptop computer with the Zip drive in the
modular bay.
Comment 1 Bill Nottingham 2001-08-22 15:00:20 EDT
How is the 100MB disk partitioned?
Comment 2 Brian Gunney 2001-08-23 00:31:29 EDT
It is unpartitioned.

In addition, when the 100MB disk is in, "fdisk /dev/hdc4" gives "Unable to read
/dev/hdc4", but "fdisk /dev/hdc" works.  And when the 250MB disk is in, "fdisk
/dev/hdc" gives "Unable to open /dev/hdc", but "fdisk /dev/hdc4" works.

When the fdisk command works, the following warning is encountered:

Device contains neither a valid DOS partition table, nor Sun, SGI or OSF disklabel
Building a new DOS disklabel. Changes will remain in memory only,
until you decide to write them. After that, of course, the previous
content won't be recoverable.
Comment 3 Bill Nottingham 2001-08-24 11:58:16 EDT
That's the problem. The initial entry is set up for partitioned disks (i.e.,
fs on fourth partition. If you put in an unpartitioned disk, you will get an error.
Comment 4 Brian Gunney 2001-08-27 11:26:06 EDT
The 250MB disk is not partitioned either.  It makes little sense to have fstab
put that disk in /dev/hdc4, but since it works, that seems ok.  But why does
that work?  Why is the default behavior to assume there is a partition number 4?
 It seems to be a poor choice to force users to know about disk partitioning
when all they want to do is write to the disk.
Comment 5 Bill Nottingham 2001-08-27 11:30:18 EDT
factory formatted disks come with everything on partition 4. dunno why, it's an
iomega quirk.
Comment 6 Brian Gunney 2001-09-08 19:50:43 EDT
Is it possible to generate two lines in fstab, one for the 4th partition and one
for the unpartitioned disk?  Well, that's not really necessary.  What is needed
is the change of ownership when a user logs in at the console.

Note You need to log in before you can comment on or make changes to this bug.