Bug 522647 - noticable freeze when skipping in Totem with nouveau driver
Summary: noticable freeze when skipping in Totem with nouveau driver
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: rawhide
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 22:58 UTC by Linus Bäcklund
Modified: 2009-10-24 14:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-24 14:07:18 UTC


Attachments (Terms of Use)
smolt profile (6.86 KB, text/plain)
2009-09-10 22:58 UTC, Linus Bäcklund
no flags Details
xorg log (106.42 KB, text/plain)
2009-09-10 23:00 UTC, Linus Bäcklund
no flags Details

Description Linus Bäcklund 2009-09-10 22:58:19 UTC
Created attachment 360580 [details]
smolt profile

Description of problem: Video temporarily halts when skipping video in totem


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. play http://www.redhat.com/v/magazine/ogg/NET_MAN.ogg in totem
2. skip back or forth
3.
  
Actual results: video halts briefly, sometimes for several seconds


Expected results: smooth playback


Additional info: switching fullscreen-mode is also choppy, visible redrawing of the screen when you switch from / to fullscreen.

Comment 1 Linus Bäcklund 2009-09-10 23:00:24 UTC
Created attachment 360581 [details]
xorg log

Comment 2 Ben Skeggs 2009-09-10 23:24:35 UTC
I can see the same issue occur here, however, it is not reproducible in other media players such as mplayer so I'm not certain its a nouveau bug at all.  How is mplayer for you?

Comment 3 Linus Bäcklund 2009-09-11 03:54:53 UTC
I apologize for the late reply, fedora hung my computer completely.
I am currently participating in the fedora nouveau test day using the testday-20090909-i686.iso, so unfortunately I don't have access to mplayer and xine is buggy when installed. I followed the instructions from https://fedoraproject.org/wiki/QA:Testcase_nouveau_xvideo, so I assumed the problem was because of nouveau. Feel free to move this bugreport, or to remove it completely.


Note You need to log in before you can comment on or make changes to this bug.