Bug 522650 (Gadgets, Google, GTK, slow) - Google Gadgets GTK's Interface is irritatingly slow.
Summary: Google Gadgets GTK's Interface is irritatingly slow.
Keywords:
Status: CLOSED ERRATA
Alias: Gadgets, Google, GTK, slow
Product: Fedora
Classification: Fedora
Component: google-gadgets
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 23:15 UTC by Justin Noah
Modified: 2010-05-15 20:27 UTC (History)
3 users (show)

Fixed In Version: google-gadgets-0.11.2-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-15 20:27:08 UTC


Attachments (Terms of Use)

Description Justin Noah 2009-09-10 23:15:54 UTC
Description of problem:

Google Gadgets GTK Interface is irritatingly slow.


Version-Release number of selected component (if applicable):

google-gadgets-gtk-0.11.0-4.fc12.i686
google-gadgets-0.11.0-4.fc12.i686


How reproducible:

Every use


Steps to Reproduce:

1. Run any gadget or try the search/add gadgets


Actual results:

Takes up to seconds for a visual response. Th
at is specifically for the search box to add items and adding items themselves.


Expected results:

To be as responsive as any other GTK application.


Additional info:

I don't know if this will matter, but I am using the xorg ati video driver however it is using the Software Rasterizer. I wouldn't think that would be an issue, but the interface that Google Gadgets uses may require better video card performance (though songbird does something similar and isn't sluggish at all).

I am using a Hyperthreaded P4 2.8GHz with an ATi Radeon HD2400 (256MB), and I have 1792MB DDR 400Mhz ram. I doubt my specs are the issue, but just in case.

Comment 1 Justin Noah 2009-09-10 23:16:32 UTC
As always, if more information is need, please let me know and I will get it asap.

Comment 2 Michel Alexandre Salim 2009-09-12 17:05:51 UTC
Does this happen if you switch (just for testing) to the vesa driver, or to ATi's binary drivers? If this only happens with xorg's ati driver then it might just be that google-gadgets is using certain visual effects that it assumed would be hw-accelerated (but is not).

Based on what happens, this would either be an xorg ati bug, or an upstream google-gadgets bug.

Comment 3 Michel Alexandre Salim 2009-09-12 17:06:02 UTC
Does this happen if you switch (just for testing) to the vesa driver, or to ATi's binary drivers? If this only happens with xorg's ati driver then it might just be that google-gadgets is using certain visual effects that it assumed would be hw-accelerated (but is not).

Based on what happens, this would either be an xorg ati bug, or an upstream google-gadgets bug.

Comment 4 Michel Alexandre Salim 2009-09-12 17:36:52 UTC
Actually, it's slow on my computer too; definitely slower than I recall in F-11. I'll try and see if anyone on F-11 notices this.

Comment 5 Justin Noah 2009-09-12 17:38:17 UTC
How do I switch to the Vesa driver? I doubt FGLRX works with the 2.6.31 kernel.

Comment 6 Justin Noah 2009-09-12 17:39:19 UTC
(In reply to comment #3)
> Does this happen if you switch (just for testing) to the vesa driver, or to
> ATi's binary drivers? If this only happens with xorg's ati driver then it might
> just be that google-gadgets is using certain visual effects that it assumed
> would be hw-accelerated (but is not).
> 
> Based on what happens, this would either be an xorg ati bug, or an upstream
> google-gadgets bug.  

I am pretty sure it is a gadgets bug, I will go report it to google..

Comment 7 Sergey Rudchenko 2009-09-12 20:06:01 UTC
On F11 box Google Gadgets works smoothly for me with both metacity(no composition) and compiz.

The default analog clock gadget ticks, gadgets are dragged very smoothly, "Add gadget" works well too.

00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated 

xorg-x11-drv-intel-2.7.0-7.fc11.x86_64

Comment 8 Michel Alexandre Salim 2009-09-13 14:24:15 UTC
Sergey: thanks!

Justin, you might want to mention that this is with Xorg 1.6.99.900 -- it's likely the Google developers only tested with 1.6 and never saw this. If you could post the upstream bug URL here after you file, that'd be great.

Comment 9 Sergey Rudchenko 2009-09-14 06:01:20 UTC
I have tested both Qt and Gtk versions on my F12 x86_64 nouveau laptop.

The Gtk version reproduces all the mentioned effects.
The Qt one is working smoothly: clock ticks, gadget moving, "Add gadget".

01:00.0 VGA compatible controller: nVidia Corporation G72M [GeForce Go 7400] (rev a1)

xorg-x11-drv-nouveau-0.0.15-9.20090910git806eaf6.fc12.x86_64

Comment 10 Sergey Rudchenko 2009-09-14 06:09:08 UTC
> I have tested both Qt and Gtk versions on my F12 x86_64 nouveau laptop.

I forgot to mention. That was a test with the metacity, w/o composition.

Looks like my chip is not fully supported yet and I can't test with compiz for now. "Desktop effects" shows "Accelerated 3D graphics is not available" for me.

Comment 11 Michel Alexandre Salim 2009-09-15 03:14:33 UTC
Justin: ah, in the old days, you just edit your /etc/X11/xorg.conf file, but everything is auto-detected now.

You can run Xorg -configure from the console within telinit 3, and then edit the file created, change the reference from "ati" to "vesa", move the file to /etc/X11/xorg.conf and then switch back to telinit 5.

But given that the problem is reproducible on Intel (me) and nVidia/nouveau (Sergey) and is GTK-specific, I'd say it's a problem specific to Rawhide (not sure which component yet) and google-gadgets-gtk.

You'd want to verify that with -qt everything works fine and then file a bug report; or let me know and I can do that on your behalf. Make sure to post a link to this bug entry when reporting it to Google.

Thanks,

-- 
Michel

Comment 12 Bug Zapper 2009-11-16 12:14:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Fedora Update System 2010-05-08 15:04:10 UTC
google-gadgets-0.11.2-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/google-gadgets-0.11.2-2.fc12

Comment 14 Fedora Update System 2010-05-10 16:57:59 UTC
google-gadgets-0.11.2-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update google-gadgets'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/google-gadgets-0.11.2-2.fc12

Comment 15 Fedora Update System 2010-05-15 20:25:59 UTC
google-gadgets-0.11.2-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.