Bug 522658 - Writer crashing on 'Save'
Summary: Writer crashing on 'Save'
Keywords:
Status: CLOSED DUPLICATE of bug 522839
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 11
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 00:15 UTC by Cyrus Taraporvala
Modified: 2009-09-12 10:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-12 10:31:33 UTC


Attachments (Terms of Use)
mapped stack (7.17 KB, text/plain)
2009-09-11 05:46 UTC, David Tardon
no flags Details

Description Cyrus Taraporvala 2009-09-11 00:15:40 UTC
Description of problem:
I recently updated xorg-x11-sever-Xorg 1.6.3-4 but had to downgrade to xorg-x11-server-Xorg-1.6.1.901-1.fc11.i586 after I kept getting reverted to my login screen.

Subsequently, I have modified a document in 'Writer' but on 'Save' it crashes with the enclosed output:

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
(II) Loading /usr/lib/xorg/modules/drivers//vesa_drv.so
(II) Loading /usr/lib/xorg/modules/drivers//fbdev_drv.so
(II) Unloading /usr/lib/xorg/modules/drivers//vesa_drv.so
(II) Unloading /usr/lib/xorg/modules/drivers//fbdev_drv.so
(==) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   openoffice.org-kde version is: package openoffice.org-kde is not installed
(V)    libgcj version is: libgcj-4.4.1-2.fc11-i586
(VI)   kernel is: Linux 2.6.30.5-43.fc11.i586 #1 SMP Thu Aug 27 21:18:54 EDT 2009 i686 i686 i386
(VII)  OpenOffice.org core rpm version is: openoffice.org-core-3.1.1-19.2.fc11-i586
(VIII) accessibility is: false
(IX)   gtk theme is: Nodoka
(X)    icon theme is: Fedora
(XI)   metacity theme is: Nodoka
(XII)  fedora release is: Fedora release 11 (Leonidas)
(XIII) LANG is: en_US.UTF-8
...start free space details ...
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup-lv_root
                      27119844   7953604  18891032  30% /
/dev/mapper/VolGroup-lv_root
                      27119844   7953604  18891032  30% /
...end free space details ...
...start (default) java details ...
java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.5) (fedora-27.b16.fc11-i386)
OpenJDK Client VM (build 14.0-b15, mixed mode)
...end (default) java details ...
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 24
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x5aedfe: 0x1c04d4: /usr/lib/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x20dfe
0x5af745: 0x1c04d4: /usr/lib/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x21745
0x486400: 0x0:  + 0x400 (__kernel_sigreturn + 0x0)
0x6494559: 0x1367a0: /usr/lib/openoffice.org/basis3.1/program/libmswordli.so + 0x62559
0x64945f1: 0x1367a0: /usr/lib/openoffice.org/basis3.1/program/libmswordli.so + 0x625f1
0x6498753: 0x1367a0: /usr/lib/openoffice.org/basis3.1/program/libmswordli.so + 0x66753
0x64993e3: 0x1367a0: /usr/lib/openoffice.org/basis3.1/program/libmswordli.so + 0x673e3
0x64999c0: 0x1367a0: /usr/lib/openoffice.org/basis3.1/program/libmswordli.so + 0x679c0
0x1002298: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x556298 (_ZN9StgWriter5WriteER5SwPaMR10SotStoragePK6String + 0xd6)
0x10020a7: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x5560a7 (_ZN6Writer5WriteER5SwPaMR8SvStreamPK6String + 0x71)
0x10021bd: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x5561bd (_ZN6Writer5WriteER5SwPaMR9SfxMediumPK6String + 0x29)
0xfa0436: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x4f4436
0x104eb91: 0xa821d8: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x5a2b91
0x2941e49: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x12ee49
0x2942d64: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x12fd64
0x2943145: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x130145
0x297faf1: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x16caf1 (_ZN12SfxBaseModel9storeSelfERKN3com3sun4star3uno8SequenceINS2_5beans13PropertyValueEEE + 0x517)
0x298bbb0: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x178bb0
0x294c919: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x139919
0x29dc0cc: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c90cc
0x29dc41b: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c941b
0x29fa3fb: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1e73fb
0x29fa3b1: 0x3c1660: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1e73b1
0x2de470a: 0x3852ec: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x20670a
0x72381e7: 0x7c4e8: /usr/lib/openoffice.org/basis3.1/program/libvclplug_genli.so + 0x481e7 (_ZN10SalDisplay21DispatchInternalEventEv + 0x97)
0x3755fab: 0x4f1d0: /usr/lib/openoffice.org/basis3.1/program/libvclplug_gtkli.so + 0x11fab
0x7baef71: 0xdd050: /lib/libglib-2.0.so.0 + 0x32f71
0x7bb0cf8: 0xdd050: /lib/libglib-2.0.so.0 + 0x34cf8 (g_main_context_dispatch + 0x1f8)
0x7bb4370: 0xdd050: /lib/libglib-2.0.so.0 + 0x38370
0x7bb44a3: 0xdd050: /lib/libglib-2.0.so.0 + 0x384a3 (g_main_context_iteration + 0x73)
0x3756073: 0x4f1d0: /usr/lib/openoffice.org/basis3.1/program/libvclplug_gtkli.so + 0x12073
0x723e775: 0x7c4e8: /usr/lib/openoffice.org/basis3.1/program/libvclplug_genli.so + 0x4e775 (_ZN14X11SalInstance5YieldEbb + 0x2f)
0x2c6f95a: 0x3852ec: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9195a (_ZN11Application5YieldEb + 0x5c)
0x2c6f9a9: 0x3852ec: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x919a9 (_ZN11Application7ExecuteEv + 0x2b)
0xa5eef5: 0x63b60: /usr/lib/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x18ef5
0x2c73aab: 0x3852ec: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x95aab
0x2c73c43: 0x3852ec: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x95c43 (_Z6SVMainv + 0x2c)
0xa831a8: 0x63b60: /usr/lib/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x3d1a8 (soffice_main + 0xd0)
0x80487c4: 0xd04: /usr/lib/openoffice.org3/program/swriter.bin + 0x7c4 (main + 0x20)
0x151a66: 0x16cd7c: /lib/libc.so.6 + 0x16a66 (__libc_start_main + 0xe6)
0x8048711: 0xd04: /usr/lib/openoffice.org3/program/swriter.bin + 0x711
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00696000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x0087e000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00110000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x0034d000)
	libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0x004af000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x001a6000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x0057c000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x00dfe000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0x001d0000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00828000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x0024b000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00647000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x002dd000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x006ff000)
	librt.so.1 => /lib/librt.so.1 (0x002e1000)
	libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x002ea000)
	libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x0069e000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x00d42000)
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x0036a000)
	libvclplug_genli.so => /usr/lib/openoffice.org/basis3.1/program/libvclplug_genli.so (0x00599000)
	libvclli.so => /usr/lib/openoffice.org/basis3.1/program/libvclli.so (0x00e09000)
	libpspli.so => /usr/lib/openoffice.org/basis3.1/program/libpspli.so (0x021ce000)
	libsotli.so => /usr/lib/openoffice.org/basis3.1/program/libsotli.so (0x00448000)
	libutlli.so => /usr/lib/openoffice.org/basis3.1/program/libutlli.so (0x0078a000)
	libtlli.so => /usr/lib/openoffice.org/basis3.1/program/libtlli.so (0x00c75000)
	libcomphelp4gcc3.so => /usr/lib/openoffice.org/basis3.1/program/libcomphelp4gcc3.so (0x044a3000)
	libucbhelper4gcc3.so => /usr/lib/openoffice.org/basis3.1/program/libucbhelper4gcc3.so (0x00d83000)
	libuno_cppuhelpergcc3.so.3 => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3 (0x02fe2000)
	libuno_cppu.so.3 => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libuno_cppu.so.3 (0x00528000)
	libvos3gcc3.so => /usr/lib/openoffice.org/basis3.1/program/libvos3gcc3.so (0x00554000)
	libuno_sal.so.3 => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libuno_sal.so.3 (0x045d4000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x00309000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x04d51000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x0061b000)
	libdl.so.2 => /lib/libdl.so.2 (0x00311000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x0062b000)
	libstlport_gcc.so => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libstlport_gcc.so (0x0340c000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x0395d000)
	libm.so.6 => /lib/libm.so.6 (0x00704000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00d17000)
	libc.so.6 => /lib/libc.so.6 (0x06ba5000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00316000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0x0033f000)
	libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x00348000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0x0067a000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00684000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x004a6000)
	libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x004a9000)
	libselinux.so.1 => /lib/libselinux.so.1 (0x006df000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0x01d8a000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x01196000)
	libz.so.1 => /lib/libz.so.1 (0x00812000)
	libexpat.so.1 => /lib/libexpat.so.1 (0x01789000)
	/lib/ld-linux.so.2 (0x0031d000)
	libcap.so.2 => /lib/libcap.so.2 (0x00577000)
	libi18npaperli.so => /usr/lib/openoffice.org/basis3.1/program/libi18npaperli.so (0x0068e000)
	libbasegfxli.so => /usr/lib/openoffice.org/basis3.1/program/libbasegfxli.so (0x011dc000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0x0072c000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0x07fa6000)
	libi18nisolang1gcc3.so => /usr/lib/openoffice.org/basis3.1/program/libi18nisolang1gcc3.so (0x00697000)
	libi18nutilgcc3.so => /usr/lib/openoffice.org/basis3.1/program/libi18nutilgcc3.so (0x03385000)
	libicuuc.so.40 => /usr/lib/libicuuc.so.40 (0x0198f000)
	libicudata.so.40 => /usr/lib/libicudata.so.40 (0xb7311000)
	libicule.so.40 => /usr/lib/libicule.so.40 (0x042ee000)
	libjvmaccessgcc3.so.3 => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libjvmaccessgcc3.so.3 (0x0086e000)
	libuno_salhelpergcc3.so.3 => /usr/lib/openoffice.org/basis3.1/program/../ure-link/lib/libuno_salhelpergcc3.so.3 (0x00875000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x0264c000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x0427f000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x004ac000)
	libattr.so.1 => /lib/libattr.so.1 (0x00879000)
	libuuid.so.1 => /lib/libuuid.so.1 (0x00df2000)
	libfreebl3.so => /lib/libfreebl3.so (0x07097000)
...end sample ldd details ...

Comment 1 David Tardon 2009-09-11 05:30:18 UTC
dtardon->cyrus: Does it crash on saving every file or just that particular one? If it's just that one, could you attach it here? Were you saving to MS Word *.doc (which version?) or to RTF? Does it crash on saving to other formats, especially to ODT?

Comment 2 David Tardon 2009-09-11 05:46:05 UTC
Created attachment 360624 [details]
mapped stack

Well, so it was .doc.

Comment 3 Cyrus Taraporvala 2009-09-11 06:04:08 UTC
yes it is a .doc extension (Microsoft Word 97) saved and created in 'Writer' earlier that crashed each time, about thrice, as mentioned above, after I downgraded to 'xorg-x11-server-Xorg-1.6.1.901-1.fc11.i586'. All gave that message that I pasted here.

I subsequently disabled dektop effects, still on 'xorg-x11-server-Xorg-1.6.1.901-1.fc11.i586', rebooted, and did not have a problem with this particular .doc extension document that I'm working on.

Comment 4 Caolan McNamara 2009-09-11 07:44:56 UTC
I'd be fairly astounded if desktop-effects or x11 really affected this. If you were able to attach the document which caused this when loaded, modified and then saved as .doc that'd be ideal.

Comment 5 Cyrus Taraporvala 2009-09-11 08:07:19 UTC
Created attachment 360643 [details]
The .doc document that caused this crash

I attach the particular .doc document that caused this issue. I have subsequently altered and saved the document a number of times. It is a university project that I have not submitted as yet, so would be grateful if you can delete the attachment after viewing what you need to do with it.

Comment 7 Caolan McNamara 2009-09-11 09:42:54 UTC
Not reproducible unfortunately, and no warnings from valgrind. Quite possible that the trigger isn't in the attached document, e.g. that its a copy of the doc which successfully saved by luck and doesn't contain the trigger anymore.

Comment 8 Caolan McNamara 2009-09-12 10:31:33 UTC

*** This bug has been marked as a duplicate of bug 522839 ***


Note You need to log in before you can comment on or make changes to this bug.