Bug 52267 - Linuxconf web access is totally hosed
Summary: Linuxconf web access is totally hosed
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-22 07:30 UTC by John Morris
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Morris 2001-08-22 07:30:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808

Description of problem:
web access is almost totally useless

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install linuxconf
2. Enable web access
3. Open port(s) in ipchains
	

Actual Results:  Nothing.

Expected Results:  Web access to linuxconf

Additional info:

After playing around with strace it looks like it wants to run in daemon
mode instead of using the stdin/stdout channel xinetd is giving it.  To
compound the problem, regardless of what is in /etc/services it binds to
port 8000.  A workaround I used was to do "linuxconf --http &>/dev/null &"
which started it up.... on port 8000 instead of 98.  There is a --port
switch, but it also makes zero difference.

Comment 1 John Morris 2002-01-18 09:34:59 UTC
Now in 7.2 it's even worse.  Now it does seem to repond to the --port 98 switch,
but it doesn't stay running.  It won't run from xinitd and still only seems to
service one connection then exit.

I know linuxconf is supposed to be scheduled for removal, but until there is a
replacement that can do what it does I need to make it work!

Comment 2 John Morris 2002-01-18 09:57:49 UTC
Correction.  Linuxconf will work on 7.2

But a line in /etc/hosts.allow with:

ALL: localhost

would not allow lynx "http://localhost:98" to work.
Adding in a line with the hostname in question and switching localhost for the
hostname in the lynx comnmand still didn't bring joy.  However, adding:

linuxconf: ALL

works.  So is this a problem with tcpwrappers, xinitd or linuxconf.... too late
to worry about such matters, it works.  Linuxconf does its own access controls
so I hope I can get away with that ALL for now.

Comment 3 Brent Fox 2002-06-05 16:19:58 UTC
Closing because we don't ship linuxconf anymore

Comment 4 Red Hat Bugzilla 2006-02-21 18:48:06 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.