Bug 522690 - Radeon Test Day: extra rubbish on second display on boot up progress screen (multihead)
Summary: Radeon Test Day: extra rubbish on second display on boot up progress screen (...
Keywords:
Status: CLOSED DUPLICATE of bug 522176
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 05:01 UTC by Dariusz Garbowski
Modified: 2009-09-17 00:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 00:51:25 UTC


Attachments (Terms of Use)
Screenshot of the second display with rubbish outside 1280x1024 area (185.73 KB, image/jpeg)
2009-09-11 05:01 UTC, Dariusz Garbowski
no flags Details
Xorg.0.log (122.63 KB, text/plain)
2009-09-11 05:18 UTC, Dariusz Garbowski
no flags Details
dmesg (97.92 KB, text/plain)
2009-09-11 06:08 UTC, Dariusz Garbowski
no flags Details

Description Dariusz Garbowski 2009-09-11 05:01:50 UTC
Created attachment 360620 [details]
Screenshot of the second display with rubbish outside 1280x1024 area

Description of problem:
Fedora 12 Radeon Test Day 2009-09-09 with i686 LiveCD

Basic Test:
Two displays connected: a) CRT, recognized as 1280x1024 @ 85 Hz - OK, b) LCD, recognized as 1920x1200 @ 60 Hz - OK

Both displays show in clone mode, though the second one shows rubbish outside of the 1280x1024 area (resolution of the first display). The rubbish contains messed up messages from kernel boot (like "Unknown boot option 'radeon.modeset=1'. Ignoring...").

Version-Release number of selected component (if applicable):
kernel-2.6.31-0.212.rc9.git1.fc12.i686
xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.i686
libdrm-2.4.12-0.9.fc12.i686
mesa-libGL-7.6-0.9.fc12.i686

How reproducible:
Always.

Steps to Reproduce:
1. Connect two displays, first one lower resolution screen that the second one.
2. Boot up Fedora.

  
Actual results:
Screenshot of the second display attached.

Expected results:
No mess outside of the area on the second display.

Additional info:
Smolt profile:
http://www.smolts.org/client/show/pub_879d3528-7516-4c8f-95eb-740c4361cf6a

Comment 1 Dariusz Garbowski 2009-09-11 05:18:56 UTC
Created attachment 360623 [details]
Xorg.0.log

Comment 2 Dariusz Garbowski 2009-09-11 06:08:18 UTC
Created attachment 360625 [details]
dmesg

Comment 3 Adam Williamson 2009-09-17 00:51:25 UTC

*** This bug has been marked as a duplicate of bug 522176 ***


Note You need to log in before you can comment on or make changes to this bug.