Bug 522698 - Random data on background during X startup on Radeon 9550
Summary: Random data on background during X startup on Radeon 9550
Keywords:
Status: CLOSED DUPLICATE of bug 522176
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 06:23 UTC by Ondrej Zary
Modified: 2009-09-17 00:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 00:52:51 UTC


Attachments (Terms of Use)
X log (90.04 KB, text/plain)
2009-09-11 06:23 UTC, Ondrej Zary
no flags Details

Description Ondrej Zary 2009-09-11 06:23:24 UTC
Created attachment 360628 [details]
X log

Description of problem:
When the X server is starting, the background is not black but full of random color data. The mouse cursor is correct. It fixes itself after a while.

Version-Release number of selected component (if applicable):
from Fedora Test Day 20090908 Live CD

How reproducible:
Always

Steps to Reproduce:
1. Boot the Live CD
 
Actual results:
Screen with random pixels and mouse cursor.

Expected results:
Black screen with mouse cursor.

Additional info:
http://www.smolts.org/client/show_all/pub_5f9620d5-17f6-4c7e-88ce-f593f33f1ed3

Comment 1 Ondrej Zary 2009-09-11 11:22:49 UTC
This happens only when two monitors are attached to the card. The background is not random, it's simply uninitialized - random on cold boot, part of previous VRAM content after reboot.

Comment 2 Ondrej Zary 2009-09-11 11:27:21 UTC
It does not happen when kernel mode setting is disabled. So it only happens with two monitors and KMS.

Comment 3 Adam Williamson 2009-09-17 00:52:51 UTC

*** This bug has been marked as a duplicate of bug 522176 ***


Note You need to log in before you can comment on or make changes to this bug.