Bug 522708 - Wrong test in amtu initscript
Summary: Wrong test in amtu initscript
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: amtu
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Grubb
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: InitScriptsProject 536887
TreeView+ depends on / blocked
 
Reported: 2009-09-11 06:50 UTC by Miroslav Vadkerti
Modified: 2010-03-11 17:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 536887 (view as bug list)
Environment:
Last Closed: 2009-09-14 13:49:48 UTC


Attachments (Terms of Use)

Description Miroslav Vadkerti 2009-09-11 06:50:48 UTC
Description of problem:
amtu initscript doesn't work with correct configuration file /etc/sysconfig/amtu. The bug is in these two tests (they always fail):

	test x"$AMTU_HALT_ON_FAILURE" = "x" || exit 6
	test x"$HALT_COMMAND" = "x" || exit 6

The correct code should be:

	test 'x"$AMTU_HALT_ON_FAILURE" = "x"' || exit 6
	test 'x"$HALT_COMMAND" = "x"' || exit 6

Version-Release number of selected component (if applicable):
amtu-1.0.8-4.fc12.i686

How reproducible:
always

Steps to Reproduce:
1. service amtu start
  
Actual results:
Doesn't start and returns 6 (not configured correctly)

Expected results:
Correctly start

Additional info:

Comment 1 Steve Grubb 2009-09-11 15:19:59 UTC
Hmm...wonder how that got in there. The correct code should be:

 test x"$AMTU_HALT_ON_FAILURE" != "x" || exit 6
 test x"$HALT_COMMAND" != "x" || exit 6

Comment 2 Steve Grubb 2009-09-11 18:49:14 UTC
I built amtu-1.0.8-5 in rawhide to solve this problem. Please give it a test. Thanks.

Comment 3 Miroslav Vadkerti 2009-09-14 10:55:42 UTC
I tested the newest package and problem seems to be fixed. Although the there is no result after the run (I mean [  OK  ] or [  FAILED  ]). It would be nice if this would be displayed.

Comment 4 Steve Grubb 2009-09-14 13:49:48 UTC
Yes, it would be nice to have pass or fail on the screen. But, there is no way to do this without patching amtu itself as best as I can tell. The basic problem is that amtu has no quiet mode and will scribble all over the screen. I will close this bug since the basic requirements have been met. Thanks for reporting the bug.


Note You need to log in before you can comment on or make changes to this bug.