Bug 52271 - Command "init 1" brings strange shell.
Summary: Command "init 1" brings strange shell.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-22 09:09 UTC by Shinya Narahara
Modified: 2014-03-17 02:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-23 00:13:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Shinya Narahara 2001-08-22 09:09:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [ja] (WinNT; U)

Description of problem:
The command "init 1" meens to be single user mode, but on
RH7.2beta, this causes a strange key input.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install RH7.2beta.
2.login as root.
3.init 1
	

Actual Results:  sh-2.05# ps
sh: s: command not found

Expected Results:  sh-2.05# ps
  PID TTY             TIME CMD
 6426 pts/0       00:00:00 su
 6428 pts/0       00:00:00 bash
 6474 pts/0       00:00:00 sh
 6475 pts/0       00:00:00 ps


Additional info:

If you input "exit" immediately after "init 1", you can input any command normaly.
I guess this is caused by multiple shell on runlevel 1.
But runlevel 1 is very useful and needed for many administrator, hence this
SHOULD be fixed.

Comment 1 Bill Nottingham 2001-08-22 19:12:10 UTC
What version of util-linux do you have installed?

Comment 2 Shinya Narahara 2001-08-23 00:13:10 UTC
util-linux is 2.11f-5.
SysVinit is 2.78-18.
initscripts is 6.10-1.

Comment 3 Bill Nottingham 2001-08-23 02:28:49 UTC
This is fixed in util-linux-2.11f-8.


Note You need to log in before you can comment on or make changes to this bug.