This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 522710 - char device redirected to /dev/pts/1 qemu: could not load kernel
char device redirected to /dev/pts/1 qemu: could not load kernel
Status: CLOSED DUPLICATE of bug 523960
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-11 02:55 EDT by Jens Petersen
Modified: 2009-09-24 11:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-24 11:32:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
virt-manager.log (9.99 KB, text/plain)
2009-09-18 01:47 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2009-09-11 02:55:44 EDT
Description of problem:
I can't seem to boot install images from virt-manager.

Version-Release number of selected component (if applicable):
virt-manager-0.8.0-2.fc12

How reproducible:
every time

Steps to Reproduce:
1. install rawhide, set permissive and reboot
2. try to install guest
3. click Finish
  
Actual results:
Unable to complete install '<class 'libvirt.libvirtError'> internal error unable to start guest: char device redirected to /dev/pts/1
qemu: could not load kernel '/home/someone/.virtinst/boot/virtinst-vmlinuz.gueuuA'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1489, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 628, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 726, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 1077, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error unable to start guest: char device redirected to /dev/pts/1
qemu: could not load kernel '/home/someone/.virtinst/boot/virtinst-vmlinuz.gueuuA'

'

Expected results:
no backtrace
Comment 1 Jens Petersen 2009-09-11 02:58:18 EDT
virt-install looks ok
Comment 2 Mark McLoughlin 2009-09-11 10:04:51 EDT
Could you include ~/.virt-manager/virt-manager.log and /var/lib/libvirt/qemu/$guest.log?

If you do chmod o+x /home/someone does it work?

qemu now runs as the qemu user instead of root. See:

  http://libvirt.org/drvqemu.html#securitydac
Comment 3 Jens Petersen 2009-09-18 01:46:10 EDT
(In reply to comment #2)
> Could you include ~/.virt-manager/virt-manager.log and
> /var/lib/libvirt/qemu/$guest.log?

Ok

> If you do chmod o+x /home/someone does it work?

No

> qemu now runs as the qemu user instead of root.

Good to know
Comment 4 Jens Petersen 2009-09-18 01:47:22 EDT
Created attachment 361597 [details]
virt-manager.log
Comment 5 Jens Petersen 2009-09-18 01:48:11 EDT
/var/lib/libvirt/qemu/ is empty
Comment 6 Mark McLoughlin 2009-09-21 09:40:39 EDT
How about "chmod o+x /home/petersen/.virtinst /home/petersen/.virtinst/boot" ?

See bug #523960

Log file is in /var/log/libvirt/qemu
Comment 7 Jens Petersen 2009-09-21 23:11:26 EDT
(In reply to comment #6)
> How about "chmod o+x /home/petersen/.virtinst /home/petersen/.virtinst/boot" ?

Bingo - thanks!

So is this a duplicate of bug 523960?

> Log file is in /var/log/libvirt/qemu

Ok, do you still need it?
Comment 8 Cole Robinson 2009-09-24 11:32:53 EDT
Nope, log file shouldn't be required. Duping to 523960

*** This bug has been marked as a duplicate of bug 523960 ***

Note You need to log in before you can comment on or make changes to this bug.