Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 522744 - X won't launch with KMS disabled
Summary: X won't launch with KMS disabled
Keywords:
Status: CLOSED DUPLICATE of bug 522551
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 09:46 UTC by Mamoru TASAKA
Modified: 2009-09-18 01:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-18 01:44:23 UTC
Type: ---


Attachments (Terms of Use)
Xorg.0.log (with nomodeset removed) (104.29 KB, text/plain)
2009-09-11 09:50 UTC, Mamoru TASAKA
no flags Details
dmesg (33.05 KB, text/plain)
2009-09-11 09:52 UTC, Mamoru TASAKA
no flags Details
lspci -vvv (10.37 KB, text/plain)
2009-09-11 09:53 UTC, Mamoru TASAKA
no flags Details

Description Mamoru TASAKA 2009-09-11 09:46:03 UTC
Description of problem:
With
- Toshiba Dynabool TX3516 (Intel® 855GME)
- rpms:
kernel-2.6.31-2.fc12.i686
xorg-x11-server-Xorg-1.6.99.900-1.fc12.i686
xorg-x11-drv-intel-2.8.0-13.20090909.fc12.i686

rebooting with adding "nomodeset" to boot parameter
will cause X no-lauching and system freeze.

Version-Release number of selected component (if applicable):
See above

How reproducible:
100%

Steps to Reproduce:
1. reboot
2. add "nomodeset" to kernel paremeter
3. boot with init 5
  
Actual results:
X won't launch, system freezes totally.

Comment 1 Mamoru TASAKA 2009-09-11 09:50:36 UTC
Created attachment 360653 [details]
Xorg.0.log (with nomodeset removed)

It seems that with nomodeset Xorg.0.log could not be saved.
Perhaps system got frozen before system could write anything
to Xorg.0.log.

Comment 2 Mamoru TASAKA 2009-09-11 09:52:28 UTC
Created attachment 360654 [details]
dmesg

dmesg (with nomodeset)

Comment 3 Mamoru TASAKA 2009-09-11 09:53:51 UTC
Created attachment 360655 [details]
lspci -vvv

Comment 4 Adam Williamson 2009-09-18 01:36:45 UTC
If it works without mode setting, then it's actually fine; I should have made it clearer that the nomodeset test is only really there as a fallback if booting with modesetting doesn't work. so, if it worked OK with modesetting, we'll close this bug as WONTFIX. could you let us know? thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Adam Williamson 2009-09-18 01:44:23 UTC
oh, look, there's an earlier report...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 522551 ***


Note You need to log in before you can comment on or make changes to this bug.