Bug 522746 - emacs have "file-error Setting current directory no such file or directory /builddir/build/BUILD/emacs-23.1/src/"
Summary: emacs have "file-error Setting current directory no such file or directory /b...
Keywords:
Status: CLOSED DUPLICATE of bug 474958
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Novotny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 09:53 UTC by Jian Lee
Modified: 2009-10-12 13:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-12 13:07:43 UTC


Attachments (Terms of Use)

Description Jian Lee 2009-09-11 09:53:12 UTC
Description of problem:

When I use emacs , I found a error -- "(file-error Setting current directory no such file or directory /builddir/build/BUILD/emacs-23.1/src/)"
I saw the builder is your about http://koji.fedoraproject.org/koji/buildinfo?buildID=129952. Maybe it use the chroot enviroment directory which create by mock on koji building system.

my emacs is :
--------------------------------
$ rpm -qa|grep emacs-23.1
emacs-23.1-6.fc12.i686
=====================


Rich info :
---------------------------------------------------
$ LANG=en_US && emacs -q -batch -l muse-init.el -f muse-project-batch-publish --force Computer.Python
Loading /usr/share/emacs/site-lisp/site-start.d/focus-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/git-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/muse-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/php-mode-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/po-mode-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/rpm-spec-mode-init.el (source)...
Publishing project Computer.Python ...
OptionParser: Error occured: (file-error Setting current directory no such file or directory /builddir/build/BUILD/emacs-23.1/src/)
  backtrace()
  byte-code("ÂÀÃÄÅ      #Æ  ÇÈÉÅ        #!Â" [muse-batch-publishing-p err boundp message "%s: Error occured: %s" muse-page-name backtrace muse-display-warning format "An error occurred while publishing %s:
==========================================================

Comment 1 Daniel Novotny 2009-09-17 11:22:03 UTC
hello,
under which circumstances the error appears?

Comment 2 Jian Lee 2009-09-17 11:40:34 UTC
No circumstances info, Just "file-error Setting current directory no such file
or directory /builddir/build/BUILD/emacs-23.1/src/" when run a lisp scripts by emacs from command .

I'm not familarity the inner in emacs. But maybe the emacs.spec let mock set the "/builddir/build/"(chroot's topdir) as some dir in emacs.

Thanks,

Comment 3 Daniel Novotny 2009-09-21 11:02:32 UTC
can you attach the "muse-init.el" script, which produces the error, when you run it? or, if this is secret, some another reproducer?

Comment 4 Daniel Novotny 2009-10-12 13:07:43 UTC
hmmm, this seems the same as  Bug 474958  - there's a better reproducer there, so I will close dup this one

*** This bug has been marked as a duplicate of bug 474958 ***


Note You need to log in before you can comment on or make changes to this bug.