Bug 522752 - Impossible to satisfy requires
Summary: Impossible to satisfy requires
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openvrml
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Braden McDaniel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 10:24 UTC by Caolan McNamara
Modified: 2009-11-04 23:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-04 23:08:21 UTC


Attachments (Terms of Use)

Description Caolan McNamara 2009-09-11 10:24:05 UTC
Description of problem:
openvrml has requires which don't exist. i.e.

"- Made dependencies on gecko-libs and java arch-specific."
leads to...
$ rpm -qp --requires openvrml-0.18.3-2.fc12.i686.rpm |grep x86
gecko-libs(x86-32) >= 1.9.1
java(x86-32)

but those don't exist, what does exist is e.g.

xulrunner(x86-32)
java-1.5.0-gcj(x86-32) or java-1.6.0-openjdk(x86-32)
but not what is explicitly being Required, 

Easy fix is to just drop the %{?_isa} stuff of course
Requires:       gecko-libs%{?_isa} >= 1.9.1
Requires:       java%{?_isa}
but presumably there was a particular problem you wanted to solve. what was it ?

Comment 1 Braden McDaniel 2009-09-11 17:14:36 UTC
That problem is documented in this fedora-devel thread:

https://www.redhat.com/archives/fedora-devel-list/2009-July/msg01366.html

openvrml's Requires are correct.  The bug is that the packages that are supposed to Provide them aren't.

Comment 2 Braden McDaniel 2009-11-04 23:08:21 UTC
These issues have been resolved by no longer using virtual packages in Requires.


Note You need to log in before you can comment on or make changes to this bug.