Bug 522770 - microcode_ctl init script is not completely LSB compliant
microcode_ctl init script is not completely LSB compliant
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: microcode_ctl (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Anton Arapov
Fedora Extras Quality Assurance
:
Depends On:
Blocks: InitScriptsProject 576531
  Show dependency treegraph
 
Reported: 2009-09-11 07:11 EDT by Yulia Kopkova
Modified: 2014-06-18 04:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 576531 (view as bug list)
Environment:
Last Closed: 2010-03-24 07:40:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yulia Kopkova 2009-09-11 07:11:05 EDT
Description of problem:
According to https://fedoraproject.org/wiki/Packaging/SysVInitScript
microcode_ctl init script should:

1. have LSB header
2. support "condrestart" and "try-restart" actions

The reason of filling this is "InitScripts LSB compliance project"

Version-Release number of selected component (if applicable):
microcode_ctl-1.17-1.53.fc12.1.x86_64
Comment 1 Yulia Kopkova 2009-09-11 10:17:26 EDT
3. The third thing, is that microcode_ctl exit code may return "19". According to LSB:
 8-99:	reserved for future LSB use
Comment 2 Yulia Kopkova 2009-09-15 08:57:29 EDT
4. Init script Should return usage and exit code "3" for unknown action.
Comment 3 Yulia Kopkova 2009-09-15 10:17:19 EDT
5. "status" action for stopped service should return exit code "3"
Comment 4 Yulia Kopkova 2009-09-17 05:27:29 EDT
6. insufficient rights
init script should also return code "4" if restarting service under
nonprivileged user:

su testuserqa -c "service $SERVICE restart"; echo $?
now: 0 
expected: 4
Comment 5 Yulia Kopkova 2009-09-24 09:05:44 EDT
(In reply to comment #2)
> 4. Init script Should return usage and exit code "3" for unknown action.  

Update:

4. Init script Should return usage and exit code "2" for unknown action.
Comment 6 Bug Zapper 2009-11-16 07:15:27 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Anton Arapov 2010-03-24 07:40:30 EDT
"fixed" within bug 479898... does not have init script anymore.

Note You need to log in before you can comment on or make changes to this bug.