Bug 522788 - orage ships own libical
orage ships own libical
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: orage (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2009-09-11 09:02 EDT by Christoph Wickert
Modified: 2011-02-19 10:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-19 10:28:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 5764 None None None Never

  None (edit)
Description Christoph Wickert 2009-09-11 09:02:23 EDT
Description of problem:
Orage ships a copy of libical an builds against it. We should link it against the libical package.
Comment 1 Kevin Fenzi 2009-09-15 14:05:39 EDT
Ugh. Good spotting. ;( 

I guess we should first contact the upstream maintainer and ask what changes he made to his local copy. Upstream is currently not dead (although they have been in the past), so perhaps we can get their changes upstreamed. 

The changelog only says: 

        * Orage is now dependent on local libical.
            - standard libical cannot be used due to several fixes
              done to Orage's private copy
Comment 2 Kevin Fenzi 2009-09-15 14:17:59 EDT
Adding link to upstream bug report.
Comment 3 Christoph Wickert 2009-09-15 15:22:59 EDT
(In reply to comment #1)
> The changelog only says: 
> 
>         * Orage is now dependent on local libical.
>             - standard libical cannot be used due to several fixes
>               done to Orage's private copy  

The private copy of libical is horribly outdated (0.2.4 vs. 0.4.3 in F11). And it's not only libical but also tzdata in the orage tarball.
Comment 4 Bug Zapper 2009-11-16 07:15:48 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Kevin Fenzi 2009-12-08 11:40:36 EST
Just to update this from the upstream report: 

The maintainer has 2 outstanding bugs filed with the ical folks, but has workarounds for them, so they have disabled the internal ical by default in favor of a system one when it's new enough. ;) 

This will likely land with the 4.8 Xfce, not sure it's possible to backport from git head. 

I'll leave this open for now as a reminder.
Comment 6 Kevin Fenzi 2010-08-23 22:55:28 EDT
ok, I have landed orage 4.7.5.16 in rawhide, which uses the system libical. ;) 

I'm going to go ahead and close this now. 

If we want to keep it open to track getting rid of it in f12/f13/f14/el5/el6, feel free to re-open it. 
I intend to push to those releases as testing indicates.
Comment 7 Thom Carlin 2011-02-19 08:02:10 EST
Hi Kevin, I show orage 4.6.1-2 currently in f14. What should be done now?
Comment 8 Christoph Wickert 2011-02-19 08:24:52 EST
I don't consider this important enough to justify an update or of orage in F13 or F14. There are massive changes in the UI and this is incompatible with our our stable updates policy (https://fedoraproject.org/wiki/Updates_Policy)
Comment 9 Thom Carlin 2011-02-19 10:04:06 EST
Should we schedule it for f15?
Comment 10 Christoph Wickert 2011-02-19 10:20:04 EST
It is already in F15, that's why the bug got closed.
Comment 11 Thom Carlin 2011-02-19 10:28:50 EST
Sorry, I see it now.  Will update FES ticket to indicate status...thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.