Bug 522792 - "usage" is listed twice in --help option of CLI commands
Summary: "usage" is listed twice in --help option of CLI commands
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: freeIPA
Classification: Retired
Component: ipa-admintools
Version: 2.0
Hardware: All
OS: Linux
low
low
Target Milestone: v2 release
Assignee: Rob Crittenden
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks: 431020
TreeView+ depends on / blocked
 
Reported: 2009-09-11 13:21 UTC by David O'Brien
Modified: 2015-01-04 23:40 UTC (History)
3 users (show)

Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-27 07:14:58 UTC


Attachments (Terms of Use)

Description David O'Brien 2009-09-11 13:21:19 UTC
Description of problem:

If you type ipa <command> --help the "usage" heading is listed twice.

Version-Release number of selected component (if applicable):
2.0

How reproducible:
Always

Steps to Reproduce:
1. Add the --help argument to any CLI command
2.
3.
  
Actual results:
# ipa-user-add --help
usage: Usage: ipa [global-options] user-add USER

Expected results:
# ipa-user-add --help
Usage: ipa [global-options] user-add USER

Additional info:

Comment 1 Pavel Zuna 2009-11-20 15:49:48 UTC
Can't reproduce anymore.

Comment 2 Jenny Severance 2011-06-10 16:54:15 UTC
Usage is slightly different now ..

# ipa help user
Users

Manage user entries. All users are POSIX users.

IPA supports a wide range of username formats, but you need to be aware of any
restrictions that may apply to your particular environment. For example,
usernames that start with a digit or usernames that exceed a certain length
may cause problems for some UNIX systems.
Use 'ipa config-mod' to change the username format allowed by IPA tools.

Disabling a user account prevents that user from obtaining new Kerberos
credentials. It does not invalidate any credentials that have already
been issued.

Password management is not a part of this module. For more information
about this topic please see: ipa help passwd

EXAMPLES:

 Add a new user:
   ipa user-add --first=Tim --last=User --password tuser1

 Find all users whose entries include the string "Tim":
   ipa user-find Tim

 Find all users with "Tim" as the first name:
   ipa user-find --first=Tim

 Disable a user account:
   ipa user-disable tuser1

 Enable a user account:
   ipa user-enable tuser1

 Delete a user:
   ipa user-del tuser1

Topic commands:
  user-add      Add a new user.
  user-del      Delete a user.
  user-disable  Disable a user account.
  user-enable   Enable a user account.
  user-find     Search for users.
  user-mod      Modify a user.
  user-show     Display information about a user.
  user-unlock   Unlock a user account


Note You need to log in before you can comment on or make changes to this bug.