Bug 522809 - Boot fails, last mount time in the future
Boot fails, last mount time in the future
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Rik van Riel
Lawrence Lim
: Triaged
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2009-09-11 11:04 EDT by Eric Paris
Modified: 2014-03-25 21:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-08 09:51:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2009-09-11 11:04:08 EDT
I've got 2 different RHEL 5.4 hosts which have shown this problem.

kvm-83-105.el5_4.1
kernel-2.6.18-164.el5
libvirt-0.6.3-20.1.el5_4

All of my guests are rawhide.  I have no idea if that is applicable.

Sometimes (not always) when I try to boot a guest it will fail to boot and drop me into filesystem recovery mode because the 'last mount time' of the / and the /boot filesystem (the only 2 filesystems inside my vms) is in the future.  The time in the future is never > 60 minutes in the future.  It does not always happen.  Another off thing is the /boot often says that it 'last modify time' is in the future (I have never seen / indicate it's last modify time was in the future)  Running fsck on both filesystems allows everything to boot just fine (until the next time)

I believe it may be reproducible by booting a vm and then crashing it or using the 'force off' option to forcibly power it down rather than rebooting it cleanly.  I'm not sure what all I can collect or do to help pin down the problem.

I do know that when the mount fsck fails and drops into recovery mode the date inside the vm is correct.
Comment 1 Dor Laor 2009-10-29 18:34:23 EDT
Pls retry to check if its rawhide or kvm
Comment 4 Glauber Costa 2010-06-30 10:28:03 EDT
Can you give us numbers about what the times are?

output of the "date -u" command before the crash, and after the crash, are welcome.
Also, please include your guest dmesg.
Comment 7 RHEL Product and Program Management 2011-01-11 15:44:51 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-01-11 17:47:01 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 10 Rik van Riel 2011-08-08 09:51:11 EDT
If this still happens and there is a way to reproduce the bug, please reopen.

Note You need to log in before you can comment on or make changes to this bug.